Cannot reconnect to WiFi after enabling and disabling Airplane mode

RESOLVED DUPLICATE of bug 938044

Status

Firefox OS
Wifi
RESOLVED DUPLICATE of bug 938044
5 years ago
4 years ago

People

(Reporter: zac, Assigned: vchang)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation][xfail])

(Reporter)

Description

5 years ago
Device Hamachi
Gecko  http://hg.mozilla.org/mozilla-central/rev/581d180a37f3
Gaia  a013d01d3a0ddee76f60e61f8306d280c10aafbf
BuildID 20131112040207
Version 28.0a1

STR:
1. Boot up device
2. Connect to WiFi
3. Load settings app, wait for Airplane mode toggle to enable
4. Tap airplace mode toggle
5. Wait a few seconds for "Disconnected" in Wifi region and "SIM Card not ready" in Carrier regions
6. Retoggle the Airplane mode
7. Wait for SIM to come back on

Observe Wifi settings - Wifi logo will come on in status bar but data is not active (try to navigate to a URL).
Tapping into Wifi in Settings app will scan a bit and then cancel, turning off WiFi.


Apologies but I've run out of time to get a clear regression range on this as I'm in my 11th hour of the day but I think it is fresh today.
The automation was broken for a different reason so the best range we can get from automation is around 5 nightly builds.
Could be caused by bug 921620's landing. A regression range will help confirm that.
Keywords: qawanted → regressionwindow-wanted

Updated

5 years ago
blocking-b2g: --- → 1.3?

Updated

5 years ago
QA Contact: jzimbrick

Comment 2

5 years ago
Regression Window:

Last Working Build Environmental Variables:
Device:  Buri v1.3 Mozilla RIL
BuildID: 20131110040200
Gaia: cc9fec48957c9d217221d403aac4b5f35a826dd6
Gecko: 16949049f03d
Version: 28.0a1
Base Image: 20131104

First Broken Build Environmental Variables:
Device:  Buri v1.3 Mozilla RIL
BuildID: 20131112040207
Gaia: a013d01d3a0ddee76f60e61f8306d280c10aafbf
Gecko: 581d180a37f3
Version: 28.0a1
Base Image: 20131104
Keywords: regressionwindow-wanted

Updated

5 years ago
Whiteboard: [fromAutomation] → [fromAutomation][xfail]
(Assignee)

Updated

5 years ago
Assignee: nobody → vchang

Comment 3

5 years ago
Ken, should we plus this one?
Flags: needinfo?(kchang)
Whiteboard: [fromAutomation][xfail] → [fromAutomation][xfail][FT:RIL]
The push log seems to strongly indicate that this is a fallout from bug 921620.
Blocks: 921620

Comment 6

5 years ago
(In reply to Kevin Hu [:khu] from comment #3)
> Ken, should we plus this one?

Sure
Flags: needinfo?(kchang)
I think this bug share the same cause as bug 938044.
(Assignee)

Comment 8

5 years ago
Hi Zac, may I confirm the issue here. After step 7, the wifi connection should come back to connected state and you can browser the internet using browser without the problem, am I right ? After that, if you turn off the wifi, we expect that the 3G data connection should reconnect automatically. But you find that 3G data connection doesn't reconnect, and you can't browser the internet. If it's the case, the should be duplicated as bug 938004 as Chuck said in comment 7.
Flags: needinfo?(zcampbell)
(Reporter)

Comment 9

5 years ago
Yes that's correct Vincent.
Flags: needinfo?(zcampbell)
(Assignee)

Comment 10

5 years ago
per comment 7~9. This should be a duplicate bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938044

Updated

5 years ago
blocking-b2g: 1.3? → ---

Updated

5 years ago
No longer blocks: 921620

Updated

5 years ago
blocking-b2g: 1.3? → ---
Whiteboard: [fromAutomation][xfail][FT:RIL] → [fromAutomation][xfail]
You need to log in before you can comment on or make changes to this bug.