gfx/2d/DrawTargetCairo.cpp:856:25: error: 'CAIRO_SUBPIXEL_ANTIALIASING_ENABLED' was not declared in this scope

RESOLVED FIXED in Firefox 27

Status

()

Core
Graphics: Text
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Jaroslav Kopecký, Assigned: Feiko Koopman)

Tracking

Trunk
mozilla28
x86
Linux
Points:
---

Firefox Tracking Flags

(firefox27 fixed, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
When trying to build firefox with --enable-system-cairo it fails on

gfx/2d/DrawTargetCairo.cpp:856:25: error:
      use of undeclared identifier 'CAIRO_SUBPIXEL_ANTIALIASING_ENABLED'
    aPermitSubpixelAA ? CAIRO_SUBPIXEL_ANTIALIASING_ENABLED : CAIRO_SUBPIXEL...
                        ^
gfx/2d/DrawTargetCairo.cpp:856:63: error:
      use of undeclared identifier 'CAIRO_SUBPIXEL_ANTIALIASING_DISABLED'
    aPermitSubpixelAA ? CAIRO_SUBPIXEL_ANTIALIASING_ENABLED : CAIRO_SUBPIXEL...
                                                              ^
2 errors generated.

This is similar to bug 623797 in that bug 363861 was never upstreamed.
(Reporter)

Updated

4 years ago
Blocks: 926023
(Assignee)

Comment 1

4 years ago
Created attachment 831291 [details] [diff] [review]
nop
Attachment #831291 - Flags: review?(matt.woodrow)
Attachment #831291 - Flags: review?(matt.woodrow) → review+
(Reporter)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/b2g-inbound/rev/5d4d2a7ffe3a
Keywords: checkin-needed

Updated

4 years ago
Assignee: nobody → feiko
https://hg.mozilla.org/mozilla-central/rev/5d4d2a7ffe3a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
(Assignee)

Comment 4

4 years ago
Comment on attachment 831291 [details] [diff] [review]
nop

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 926023, backported to Firefox 27.
User impact if declined: Failing build with --enable-system-cairo.
Testing completed (on m-c, etc.): m-c, m-a
Risk to taking this patch (and alternatives if risky): Very low
String or IDL/UUID changes made by this patch: None
Attachment #831291 - Flags: approval-mozilla-beta?
Attachment #831291 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/109c230d4915
status-firefox27: --- → fixed
status-firefox28: --- → fixed
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.