If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Helix][yangshiqi][video]the file in attachment can't be recognized by video,but it can be played through transfered by bluetooth.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Video
P2
blocker
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: lecky, Assigned: vsireesha246)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.72 Safari/537.36

Steps to reproduce:

【Detail Description*】:[B2G][Helix][yangshiqi][video]the file in attachment can't be recognized by video,but it can be played through transfered by bluetooth.
                         1. put the video in cellphone,check the video for result.
                         2. transfer the file by bluetooth ,when the transmission complete,tab the notification in statusbar,to play it
【Expect Result*】:it can be play and recognize in both the suitation.
【Real Result*】:it can be play by tab the statusbar's notification,but it can not be play by the video.
【Test Count*】:5
【Found Count*】:5
【Gaia commit ID*】:
【Gecko commit ID*】: 
【Network environment】:
【Resume operation】:
【Carrier】:
(Reporter)

Updated

4 years ago
Priority: -- → P2
(Reporter)

Updated

4 years ago
Severity: normal → blocker
(Reporter)

Comment 1

4 years ago
Created attachment 831397 [details]
20131108055241FM.3gpp
Thanks for this bug.

The main portion of video app process it correctly. This video only contains audio stream. In the metadata parsing procedure, we banned this video out. But we only discard the resize procedure in open activity. It should be also banned by video app.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

4 years ago
hi,by the way ,I just want to ask if this issue would be fixed in v1.1 hd ?
Flags: needinfo?(johu)
Hi Lecky,

No, we don't started, yet. The patch for this bug may be simple. It just need to show the "unsupported" message to user. I back to this bug when I am free.
Flags: needinfo?(johu)
(In reply to lecky from comment #3)
> hi,by the way ,I just want to ask if this issue would be fixed in v1.1 hd ?

If you want this fix landed to v1.1hd, please nominate it as hd?
(Assignee)

Comment 6

4 years ago
Hi John,

I modified the function like below..Please provide your feedback

dom.player.onloadedmetadata = function() {

	   if (!dom.player.videoWidth || !dom.player.videoHeight) {
		  handleError(navigator.mozL10n.get('error-unsupported'));
                  return;
	   }
      dom.durationText.textContent = MediaUtils.formatDuration(
        dom.player.duration);
      timeUpdated();

      dom.play.classList.remove('paused');
      setPlayerSize();

      dom.player.currentTime = 0;

      // Show the controls briefly then fade out
      setControlsVisibility(true);
      controlFadeTimeout = setTimeout(function() {
        setControlsVisibility(false);
      }, 2000);

      play();
    };
Flags: needinfo?(johu)
Assignee: nobody → vsireesha246
This patch looks good. I had tested it. It works as expected. Please update it as a pull request and set the review flag.
Flags: needinfo?(johu)
(Assignee)

Comment 8

4 years ago
Created attachment 8351166 [details]
Pointer to Pull Request.html https://github.com/mozilla-b2g/gaia/pull/14932

Hi John,

Would you please review the patch and let me know your review comments.

Thanks..
Sireesha.
Attachment #8351166 - Flags: review?(johu)
Comment on attachment 8351166 [details]
Pointer to Pull Request.html https://github.com/mozilla-b2g/gaia/pull/14932

sireesha,

Thanks for this patch. It looks and works good. Please add more comments about why we add this if condition. After that, please ping me to merge and update this bug for you. Thanks.
Attachment #8351166 - Flags: review?(johu) → review+
(Assignee)

Comment 10

4 years ago
Created attachment 8351296 [details]
Pointer to Pull Request.html

Hi John,

I made new PR with review comments and please review it.

Thanks & Regards,
Sireesha.
Attachment #8351166 - Attachment is obsolete: true
Attachment #8351296 - Flags: review?(johu)
Comment on attachment 8351296 [details]
Pointer to Pull Request.html

This version looks better.
Attachment #8351296 - Flags: review?(johu) → review+
merged to master:
https://github.com/mozilla-b2g/gaia/commit/bc7cf510efeee01fe05381b6b6e670645ca4f421
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please ensure that commit messages have a bug number and proper description of the fix. It looks like the commit message in this patch may have been rebased improperly before landing?

I've backed out the original patch, and re-landed with a better description.
https://github.com/mozilla-b2g/gaia/pull/14945
https://github.com/mozilla-b2g/gaia/commit/a51169c5fbeb12ef0688eda700d1000f0279deb9

Needsinfo on patch author and reviewer so you guys are aware.
Flags: needinfo?(vsireesha246)
Flags: needinfo?(johu)
(Assignee)

Comment 14

4 years ago
I will make sure to add proper commit message with bug no.
Flags: needinfo?(vsireesha246)
Thank you, Kevin. I will double check about that in the future. Thanks for description modification.
Flags: needinfo?(johu)
Hi John, as you know from offline, the fix of this bug corrupts the RTSP audio feature in FFOS v1.4.
I filed bug 963565 to track this issue. Please suggest how do we follow up the problem in this bug.
Flags: needinfo?(johu)
Let's discuss there.
Flags: needinfo?(johu)
The patch in this bug caused the regression in bug 956142.
Blocks: 956142
Blocks: 963565

Comment 19

4 years ago
This is actually a WONTFIX bug which caused regressions, I am reopening it and have reverted it to fix the regressions. Please see https://bugzilla.mozilla.org/show_bug.cgi?id=956142#c28 for detail.

Reverted on master: b830c213a75be8e24315e70a0bda9e8ba01f6339
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 20

4 years ago
I am closing this bug as WONTFIX since the actual result is by design.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX

Updated

4 years ago
See Also: → bug 978673
You need to log in before you can comment on or make changes to this bug.