Empty address bar if firefox use addons with getBrowser() function

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Dmitry Loginov, Unassigned)

Tracking

22 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 831419 [details]
source code for create 2 simple addons

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0

1) install 2 simple addon (xul+js, js use only getBrowser() function on start) see attach
2) restart firefox
3) open any document with local href (<a href="subdir/page.html"/>)
4) press mouse right button on this href and select "Open link in new window"



Actual results:

new window open with empty address bar


Expected results:

new window open with url in address bar
(Reporter)

Updated

5 years ago
Severity: normal → major
Hardware: x86_64 → x86

Comment 1

5 years ago
Could you attach your add-ons as simple .xpi files, please.
Flags: needinfo?(qrealka)
(Reporter)

Comment 2

5 years ago
Created attachment 832116 [details]
addons_xpi.zip

added 2 addons xpi to attachments
Flags: needinfo?(qrealka)

Comment 3

5 years ago
WFM with FF25+, see http://i.imgur.com/w8Vk8U7.jpg

Could you update to Firefox 25 and tets with a clean profile (and your add-ons installed), please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(qrealka)
(Reporter)

Comment 4

5 years ago
FF25+ is fine. fixed
Flags: needinfo?(qrealka)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.