Short HTML5 audios doesn't stops playing when using audio.stop() function

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: artnikpro, Unassigned)

Tracking

({testcase})

25 Branch
mozilla29
x86
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

Go here: http://jsfiddle.net/dbqV9/2/
Click on the first "play" link then on the next "pause" link


Actual results:

The first "pause" doesn't working, the second one (bottom) is working


Expected results:

I think the reason why it doesn't works is because the first audio is short, about 3 sec. Or maybe the problem with codec. But it works good in Chrome.

The first audio was encoded with ffmpeg, ( -acodec libmp3lame )

PS: And also the first "play" button works pretty buggy

I'm on Windows 7 x86
(Reporter)

Updated

5 years ago

Comment 1

5 years ago
Created attachment 831570 [details]
short_audio.mp3

Comment 2

5 years ago
Created attachment 831571 [details]
long_audio.mp3

Comment 3

5 years ago
Created attachment 831574 [details]
testcase_938076.html

Comment 4

5 years ago
Probably an issue with the MP3 decoder.
Component: Untriaged → Video/Audio
Product: Firefox → Core
This is WFM testing against

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140318013849 CSet: 904eb7fb178c
+
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140324030203 CSet: fa098f9fe89c

Reopen if you can repro with Firefox 29 or newer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.