[hamachi][fugu]Bluetooth still work when turn on airplane mode

RESOLVED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Xinhe Yan, Assigned: dwi2)

Tracking

unspecified
1.4 S1 (14feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

(Whiteboard: [ETA:2/7], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.04 Chromium/18.0.1025.151 Chrome/18.0.1025.151 Safari/535.19

Steps to reproduce:

1 turn on Bluetooth and turn off Aireplane mode
2 restart phone
3 turn on airplane mode, Bluetooth works   --->KO
4 turn off Bluetooth and then turn on Bluetooth
5 turn off Aireplane mode and then turn on Aireplane mode 
6 Bluetooth is still open   --->KO


Actual results:

Bluetooth still work in some case when turn on airplane mode


Expected results:

Bluetooth should close when turn on airplane mode
(Reporter)

Updated

4 years ago
Component: General → Gaia::Settings
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
blocking-b2g: --- → koi?
I reproduced this on Hamachi.

Test Build: 20131118004001
gaia: 7a23f8c53ba97da9c63a7275b36d155b4526a639
gecko: 14432474328e7558902329c3fc2a8238c3222a7f

Reproduce Steps:
1. start device
2. Turn on Bluetooth
3. Turn on Airplane mode
   => Bluetooth is off
4. Turn on Bluetooth
   => Airplane mode is on. but Bluetooth works.
5. Turn off Airplane mode
6. Turn on Airplane mode
   => Bluetooth is still on.
   => Expected: Bluetooth should be turned off.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Component: Gaia::Settings → Bluetooth
Let me check! Thanks.
Assignee: nobody → gyeh
Hi Arthur, please see my comments below and correct me if I was wrong. Thanks.

(In reply to pcheng from comment #1)
> Reproduce Steps:
> 1. start device
> 2. Turn on Bluetooth
> 3. Turn on Airplane mode
>    => Bluetooth is off
> 4. Turn on Bluetooth
>    => Airplane mode is on. but Bluetooth works.

We expect that Bluetooth should be turned on in this scenario.

> 5. Turn off Airplane mode
> 6. Turn on Airplane mode
>    => Bluetooth is still on.
>    => Expected: Bluetooth should be turned off.

Bluetooth should be turned off but it isn't. I can also reproduce this issue. Arthur, can you help to check it?
Flags: needinfo?(arthur.chen)
Forgot to mention that we didn't turn Bluetooth off at step 6, so Bluetooth can still work.
The result of step 4 is expected. As for step 6, bluetooth should be turned off.
Flags: needinfo?(arthur.chen)
Hi Xinhe,

I had no luck to reproduce this issue.

(In reply to Xinhe Yan from comment #0)
> Steps to reproduce:
> 
> 1 turn on Bluetooth and turn off Aireplane mode
> 2 restart phone
> 3 turn on airplane mode, Bluetooth works   --->KO

When I turned on airplane mode, Blueototh is turned off automatically.


> Actual results:
> Bluetooth still work in some case when turn on airplane mode

Did I miss any step? Is there any other STR you can provide?
Assignee: gyeh → nobody
Component: Bluetooth → Gaia::Settings
Created attachment 8335208 [details]
adblogcat_V1.2.log

I reproduced this with Hamachi V1.2 build
Gaia:     9439907a255e04de4c33493fe03d6670c8256e2f                           
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/fe2a7f0db27b  
BuildID   20131119004006                                                      
Version   26.0  

But I didn't restart phone. Could you please try following steps:
1. Turn on Bluetooth
2. Turn on Airplane mode
3. Turn on Bluetooth
4. Turn off Airplane mode
5. Turn on Airplane mode
   => Bluetooth is still on.
   => Expected: Bluetooth should be turned off.


Attached is the adblogcat. 
Timestamp is 11-20 18:45:08.199
(In reply to pcheng from comment #7)
> Created attachment 8335208 [details]
> adblogcat_V1.2.log
> 
> I reproduced this with Hamachi V1.2 build
> Gaia:     9439907a255e04de4c33493fe03d6670c8256e2f                           
> Gecko:    http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/fe2a7f0db27b
> 
> BuildID   20131119004006                                                    
> 
> Version   26.0  
> 
> But I didn't restart phone. Could you please try following steps:
> 1. Turn on Bluetooth
> 2. Turn on Airplane mode
> 3. Turn on Bluetooth
> 4. Turn off Airplane mode
> 5. Turn on Airplane mode
>    => Bluetooth is still on.
>    => Expected: Bluetooth should be turned off.
> 
> 
> Attached is the adblogcat. 
> Timestamp is 11-20 18:45:08.199

(In reply to Gina Yeh [:gyeh] [:ginayeh] from comment #6)


Please ignore comment 7

> Hi Xinhe,
> 
> I had no luck to reproduce this issue.
> 
> (In reply to Xinhe Yan from comment #0)
> > Steps to reproduce:
> > 
> > 1 turn on Bluetooth and turn off Aireplane mode
> > 2 restart phone
> > 3 turn on airplane mode, Bluetooth works   --->KO
> 
> When I turned on airplane mode, Blueototh is turned off automatically.
> 
> 
> > Actual results:
> > Bluetooth still work in some case when turn on airplane mode
> 
> Did I miss any step? Is there any other STR you can provide?
After the bug in step 6 is reproduced, restart phone, I saw this issue
(Reporter)

Comment 9

4 years ago
(In reply to Gina Yeh [:gyeh] [:ginayeh] from comment #6)
As pchen said in comment 8, After the bug in step 6 is reproduced, restart phone,open airplane mode, then you can saw bluetooth is still work

1
(Reporter)

Comment 10

4 years ago
Make sure Bluetooth and Aireplane mode all turn off
1 turn on Aireplane mode and turn on Bluetooth
2 turn off Aireplane mode
3 restart phone
4 turn on airplane mode and Bluetooth still work
QA,

Please check if this is a regression issue. Would be nice to also have the regression window.
Keywords: qawanted

Updated

4 years ago
QA Contact: sarsenyev

Comment 12

4 years ago
The issue reproduces on 1.1, 1.2, 1.3 builds
To reproduce the issue on 1.2 follow the steps from the comment 10
But to be able to reproduce it on 1.1 and 1.3 additional steps are required
 
Make sure Bluetooth and Airplane mode are turned off
1 turn on "Airplane mode" and turn on "Bluetooth"
2 turn off "Airplane" mode
3 restart the device
4 turn on "Airplane" mode 
5 Manually turn on "Bluetooth"
6 Toggle "Airplane" mode on/off

Reproducible rate 100%

Actual result:
After restarting the device and manually turning on the "Bluetooth" and then toggling the "airplane" mode on/off, 
the "Bluetooth" is shown active in airplane mode all the time

1.2
Device: Buri 1.2
BuildID: 20131120004000
Gaia: 5ec2963fff60492c840707df8d8090f9908a5251
Gecko: 2d454e0de2ed
Version: 26.0
Firmware revision: V1.2_US_20131115

1.3
Device: Buri 1.3 Central
BuildID: 20131120040202
Gaia: c26480b22ce28c812c347290dd4bad090d83db6f
Gecko: 4f993fa378eb
Version: 28.0a1
Firmware revision: US_20131104

1.1
Device: Leo 1.1 MOZ RIL
BuildID: 20131119041201
Gaia: b585b32441fafa67f2b4582db23be5f3a2afab21
Gecko: 7c3cfc0936ca
Version: 18.0
Firmware version: V10c
Keywords: qawanted
Not a regression, which makes this a non-blocker.
blocking-b2g: koi? → -

Updated

4 years ago
Flags: needinfo?(tzhuang)
(Assignee)

Updated

4 years ago
Assignee: nobody → tzhuang
Flags: needinfo?(tzhuang)
(Assignee)

Comment 14

4 years ago
Created attachment 8341564 [details] [review]
pull request

Hi Arthur, 

I am not sure if this patch is good enough, please help to give some feedback.

I add five setting observers in airplane_mode.js of system apps to observe if user toggle something on manually, and set the corresponding 'suspended' state to false.

I also remove the 'suspended' state guard in wifi.js of settings app, since airplane_mode.js of system app take care of that.
Attachment #8341564 - Flags: feedback?(arthur.chen)

Updated

4 years ago
blocking-b2g: - → fugu+
(Assignee)

Comment 15

4 years ago
Comment on attachment 8341564 [details] [review]
pull request

Hi Evelyn,
Please kindly help to review the patch. Thanks
Attachment #8341564 - Flags: review?(ehung)
After discussed with our partner, it will not block fugu.
blocking-b2g: fugu+ → ---
Comment on attachment 8341564 [details] [review]
pull request

Since Arthur and EJ are working on cleaning up airplane mode, I will let them review this patch to align their plan.
Attachment #8341564 - Flags: review?(ehung)
Attachment #8341564 - Flags: review?(arthur.chen)
Attachment #8341564 - Flags: feedback?(ejchen)
Attachment #8341564 - Flags: feedback?(arthur.chen)
Comment on attachment 8341564 [details] [review]
pull request

Sorry for the late reply, Tzu-Lin.

Can you try to rebase and apply your changes based on newest airplane mode design ? If you need help, don't be hesitated to tell me !

Big thanks :)
Attachment #8341564 - Flags: feedback?(ejchen)
Comment on attachment 8341564 [details] [review]
pull request

Please consolidate the initialization of the settings object. Thanks.
Attachment #8341564 - Flags: review?(arthur.chen)
(Assignee)

Comment 20

4 years ago
Comment on attachment 8341564 [details] [review]
pull request

Hi Arthur,

Please kindly help to review the patch, thanks


Hi EJ,

Since I modify the code related to airplane mode, please kindly give me some feedback. Thanks
Attachment #8341564 - Flags: review?(arthur.chen)
Attachment #8341564 - Flags: feedback?(ejchen)
Comment on attachment 8341564 [details] [review]
pull request

It works well! Just leave the reviewing process to Arthur :) 

Thanks !
Attachment #8341564 - Flags: feedback?(ejchen) → feedback+
Blocks: 960861
Comment on attachment 8341564 [details] [review]
pull request

Please check my github comments, thanks!
Attachment #8341564 - Flags: review?(arthur.chen)
(Assignee)

Comment 23

4 years ago
Comment on attachment 8341564 [details] [review]
pull request

Hi Arthur,

I've addressed your comments. Please help to review it again, Thanks
Attachment #8341564 - Flags: review?(arthur.chen)
Comment on attachment 8341564 [details] [review]
pull request

Feedback+ as I'm not a peer of the system app.
Attachment #8341564 - Flags: review?(arthur.chen) → feedback+
Nominate for 1.3+ as it blocks a 1.3 blocker.
Blocks: 960706
blocking-b2g: --- → 1.3?
(In reply to Arthur Chen [:arthurcc] (OOO 1/30 ~ 2/4) from comment #25)
> Nominate for 1.3+ as it blocks a 1.3 blocker.

I don't think this is right bug to take here - that bug points to a regression, where as this bug is not. Clearing flags.
No longer blocks: 960706
blocking-b2g: 1.3? → ---
Triage: Please read bug 960706 comment 24 and respect the estimation of engineers who work on this bug.
Blocks: 960706
blocking-b2g: --- → 1.3?
Actually, if we could make people feel better by dup this bug to bug 960706 and submit a patch there, please do, since according to bug 960706 comment 22 we fix that bug with the patch here.

I really don't want to spend time arguing on Bugzilla bureaucracy.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #28)
> Actually, if we could make people feel better by dup this bug to bug 960706
> and submit a patch there, please do, since according to bug 960706 comment
> 22 we fix that bug with the patch here.
> 
> I really don't want to spend time arguing on Bugzilla bureaucracy.

Nah, don't worry about it. I'll just + this here.
blocking-b2g: 1.3? → 1.3+
(In reply to Jason Smith [:jsmith] from comment #29)
> Nah, don't worry about it. I'll just + this here.

Thank you very much.
(Assignee)

Updated

4 years ago
Whiteboard: [ETA:2/7]
Duplicate of this bug: 960706
Note that please also ensure the issue reported in bug 960706 gets fixed with the patch.

Updated

4 years ago
No longer blocks: 960706
(Assignee)

Comment 33

4 years ago
Comment on attachment 8341564 [details] [review]
pull request

Hi Arthur,
I added unit tests for the patch. Please kindly help to review it, thanks.
Attachment #8341564 - Flags: review?(arthur.chen)
Comment on attachment 8341564 [details] [review]
pull request

r=me. Thank you for the effort!
Attachment #8341564 - Flags: review?(arthur.chen) → review+
(Assignee)

Comment 35

4 years ago
travis is green now
https://travis-ci.org/mozilla-b2g/gaia/builds/18329046

landed on master
https://github.com/mozilla-b2g/gaia/commit/7689a80de843f12ad99b0fd6c19cb7040aba0634
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-b2g-v1.3: --- → affected
status-firefox30: --- → fixed
Uplifted 7689a80de843f12ad99b0fd6c19cb7040aba0634 to:
v1.3: 2688798a90a19d8869631e78e82f160005cd4545
status-b2g-v1.3: affected → fixed

Updated

4 years ago
Flags: in-moztrap?
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
status-firefox30: fixed → ---
Target Milestone: --- → 1.4 S1 (14feb)
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.