lightning: invitation accept email is send by first account of thunderbird without notion

RESOLVED WONTFIX

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: ulf.dambacher, Unassigned)

Tracking

Lightning 2.6.2
x86_64
Linux

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131107162043

Steps to reproduce:

I have 4 different email accounts (imap) registered within thunderbird, name them #1,#2,#3,#4
I have 4 different outgoing email smtp servers  $1,$2,$3,$4 registered and paired with the incomming mail accounts

I got an invitation to a meeting via email on account #3
I pressed the accept invitation and send answer mail

thunderbird 24.1 
Lightning 2.6.2


Actual results:

the answer mail goes out via smtp server $1 (paired with account #1)
it looks like i will not attend because I did not send an answer with my email
the caller gets an answer from an email account he didn't invite and is puzzled



Expected results:

the answer mail should be send from the same account the inivitation mail was incomming.

Comment 1

4 years ago
This may be a Thunderbird or MailNews Core problem, but moving to Calendar first as the initiating component of the issue.
Component: Untriaged → E-mail based Scheduling (iTIP/iMIP)
Product: Thunderbird → Calendar
Version: 24 → Lightning 2.6.2

Comment 2

4 years ago
Lightning uses the email account that is specified in the calendars properties dialog. Maybe you assigned the first email account for this calendar?
(Reporter)

Comment 3

4 years ago
@stefan sitter:
I did not find any toggle to change this in the properties dialog.

i looked at:
* thunderbirds properties and the calendar tab and subtabs therein
* the calendar properties tab accessible by right click on the calendar (also accessable via menu)

I did not find any propertty to change this in prefs.js either.
Can you point me to it?
(Reporter)

Comment 4

4 years ago
Ok I played with the dialogs, they depend on what calendar is selected by default!
Currently I have 3 calendars: google calendar, private calendar and bank holidays from google.

If I select the google calendar (I normally do to sync with my phone) there is no "email" property
if I select the private calendar there is one and yes it is set to be the first account.

And the invitation is inserted in the private calendar by default, and not to the google calendar.
I did not get this. Annoying!

Where can I decide to wich calendar an invitation is registered?

Comment 5

4 years ago
Sounds like you are using the Provider for Google Calendar extension. Calendars created via this provider don't support invitations. Therefore this calendars can't be used as a target when accepting the invitation and they don't require an email account.
(Reporter)

Comment 6

4 years ago
Yes I use the google provider. Have to check how to do invitations with google then.
But my initial problem is that the return mail is not send with the same mail account as the invitation is received !
(until I set this account previously, explicitely)
So if I get invitations to different accounts they will be answered from the account specified in the calendar properties.
This is wrong behaviour.

Comment 7

4 years ago
I wouldn't call it 'wrong'.
I recently walked into the invitation code to solve another problem. For Lightning there's only the invitation itself visible. But these never contain information about the identity actually invited. They always contain all attendees, and Lightning concentrates only on the ones flagged as 'NEEDS-ACTION'.

So right now, it depends on the calendar, that you choose to import the event to, as explained in Comment 2. The response is always send with this identity.

Knowing that you use Google calendars that do not support invitations at all, the fact that you send out a response and assuming you knewer see a dialog that prompts you to choose a destination calendar, I guess you have another calendar, maybe on local storage that you configured with your first mail address.
Maybe caused by the problem I'm working on these days, the event never shows up on this calendar, when it's already been found in some other calendar. But the invitation response is still beeing sent with this identity.

To workaround this, you might set the assigned email account of the additional calendar to "None" or simply delete the calendar, if you do not use it. But you won't get any response mail in that case, simply because Google Calendars do not support invitations - sorry.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.