Choose the best tech / engineering path for Webmaker's events platform

RESOLVED FIXED

Status

Webmaker
webmaker.org
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: OpenMatt, Assigned: humph)

Tracking

Details

(Whiteboard: [crossteambugs])

Attachments

(1 attachment)

* GOAL: figure out the best way for Webmaker.org to support events in the medium and long term. This requires more engineering research, analysis and nuance to get right.  


* What we need next: more research and analysis from our engineering team around these potential paths:

** 1) fix what we've already built
** 2) re-write from scratch
** 3) fork / borrow from Moz Reps event platform (challenge = Django vs Node)
** 4) do something else 


Let's carefully consider: 
** current issues & what we've learned from them
** the real cost, complexity and time required
** ongoing requirements & scope creep
(Reporter)

Comment 1

4 years ago
* Here's is Dale's current research on this:
https://webmaker.etherpad.mozilla.org/925764
(Reporter)

Comment 2

4 years ago
QUESTION @ DALE: who's the right person to connect with on this from the Moz Reps side? Can you CC them on this ticket?
Assignee: nobody → david.humphrey
Status: NEW → ASSIGNED
(Reporter)

Comment 3

4 years ago
* We basically ruled out the MozRep forking idea today, because of the Django vs Node issue. So option (3) is ruled out. 

* What we decided to do next: 
option 1 in the short term, 
option 4 in the longer term

* The goal: we want to find the Transifex equivalent for our global events platform. An events platform is like an entire product unto itself. Rather than building that from scratch, what's a service or third-party solution with an API we can plug into instead?

* We need to do more research into this question. 

* Let's tap our social networks with that question. What are other smart orgs using to help solve this problem? Let's generate a list of potential solutions so we can evaluate them.

See for example
https://twitter.com/OpenMatt/status/400704758513958912
https://twitter.com/OpenMatt/status/400704007779667968
(Reporter)

Comment 4

4 years ago
Other event platform implementation examples from @NZN on Twitter: 

* Startup Weekend: http://t.co/lS91VQcIIJ 
* Maker Faire: http://t.co/GHQVyWefWQ
* IdTech: http://t.co/XjLCYvCiLa
(Reporter)

Comment 5

4 years ago
From Brett via email:

* Start-Up Weekend: http://startupweekend.org/events/
* Brett thinks this a good example of what we could/should do with events in 2014.  

High level thoughts:

a) it would be a seperate app from webmaker.  It needs its own UX, in the same way our tools do
b) it should be makerparty.  makerparty.webmaker.org
c) It should be an extension of Mozfest - like the "tedx" of mozfest
d) it should be centered around web literacy to re-inforce our brand and focus.  So in the same way startup weekend is clear "make a startup in a weekend" - ours should be "It takes all kinds to build the web.  
e) We'll show you how" or something to this effect 
f) like startup weekend, the heavy lifting of registration should be done by 3rd party like eventbrite
g) i like that in this setup, each event gets a "page" - that's useful.  You could imagine adding makes + photos that are tagged a certain way
(Reporter)

Comment 6

4 years ago
From Chris Lawrence via email:

* A big +1 to all of this, especially starting now, using third party event reg and separate app

* I think the Mozfest piece needs more discussion, contemplation but that shouldn't hinder getting momentum on the rest

Comment 7

4 years ago
The startup weekend page is a great example and the closest I've seen to a model that we should replicate. Thanks for finding Matt. 

I am going to filter through the feedback and put together a list (in order) of priorities for the events page as requested by the community for the current and beyond page. 

I've got a bit of a background in tech mapping so will ask around to my contacts what api's would be good to pull.
(Reporter)

Comment 8

4 years ago
This is shaping up great. Nice work team! :)
I think we're at a point where we should close this ticket and file some new more granular ones
(Reporter)

Comment 9

4 years ago
Trying to process the various comments above, I think we're undertaking work on three distinct fronts.
Like a clubhouse sandwhich

=====================================
Webmaker's Events platform: 3 layers
=====================================


1) Technology / app / back end
=====================================
* Do we know what app / platform / approach Startup Weekend is using? 
* Their site says it was: 
** designed by Moosesyrup http://moosesyrup.com/
** developed by Cremalab http://cremalab.com/
* Should we reach out and get in touch with these folks? 


2) UI / front end / HTML
=====================================
* Some of the changes Amira is after (like adding prominent links to the event guides, etc.) can be addressed through changes in the interface with a little HTML and CSS. *They don't have to be blocked on improvements in the back end.* 
* Whatever platform or app we choose, we will also need solid design thinking / interaction design / page design as well as a great back-end API etc. 
* QUESTION: Who should we assign that design work to? 


3) Branding / naming / labeling
=====================================
* To Brett's point around labeling / branding things as "Maker Party" and "MozFest": +1 to CLAW: more discussion needed. 
* I don't disagree. But I would like to separate / uncouple the branding logic from the technology / app / back-end logic.
* They don't really have to inter-depend on each other that much.
(Reporter)

Comment 11

4 years ago
* EventBrite has a page with apps that have been built on their platform as well:
https://www.eventbrite.com/l/partners?ref=partner
(Reporter)

Comment 12

4 years ago
* Filed this one:

Research how Startup Weekend does their event platform
https://bugzilla.mozilla.org/show_bug.cgi?id=938760


* @ Humph: any other tickets you think we should file in terms of specific research or next steps?
(Reporter)

Comment 13

4 years ago
* Another one to look at: http://themakermap.com/
(Reporter)

Comment 14

4 years ago
* I reached out to the folks responsible for http://startupweekend.org/events/ -- waiting to hear back

* This seems like the best of the examples we've looked at above

* Of the other examples we've looked at, what else stands out?

Comment 15

4 years ago
Great Matt. The startup page is the most ideal to me so glad we've reached out. 

In some sort of order, below is the preferences of what our community wants out of the /events page. I think they're searching for some sort of community hub within the page and ways to interact more.

Immediate:
-confirmation when uploading events, ability to click submit and know that your event has been processed (so people don't click and upload 100 times), improved process of uploading images/editing event info
-easier way to search events page (search by term) and find events in an area
-lists of upcoming events
-placement on page of event guides, teaching kits and resources to run an event. They really want a step-by-step guide to events that is located on the page. I think we have this but it's a matter of working it into the page 
-If I upload an event for someone I should be able to switch it to their account or email afterwards. 

Future:
-better direction on getting involved and knowing the story they are apart of (like this http://startupweekend.org/organizer/ or the number count on the top of the page here http://startupweekend.org/events/)
-feature blogs of past events (published on Webmaker blog and event hosts blogs) or spotlight recent events and what they did. They want better recognition and identification of organizers. 
-community forum to discuss problems or share post-event info 
-find events they've done in the past 
-direction on where to go to 1) get technical help, 2) get help in planning their event, 3) locate local partners and supports, 4) access more resources or 5) ask questions
(Reporter)

Comment 16

4 years ago
Fantastic list. Thanks Amira.
(Reporter)

Comment 17

4 years ago
* I spoke with George from CremaLab today (the folks behind the Startup Weekend site)
* I outlined our basic requirements and learned more about the work they did for Startup Weekend.

* Next steps: George is going to do some additional research on his side. Will report back here end of this week.

* A few early notes:

** They're cool with open source. It's their preferred way to work as well. It just depends on the client and specific tools. 
** They like working in Node.
** The work they did for Startup Weekend is now a couple years old. And was initially done using WordPress. They're interested in the idea of re-creating it using Node.
(Reporter)

Comment 18

4 years ago
* I just heard back from George at CremaLab. He's been researching two potential options:
** 1) reskin what they they already built, and hand it over to us.
** 2) re-build it in Node. since it was originally created on WordPress.

* Their recommendation: rebuild in Node. To better fit with our own technical focus. And also update and improve what they originally built two years ago. 

* How they would tackle it: boil down the features, functionality and scope they build for Startup Weekend. Then evaluate how it could be rebuilt in a new stack.
* This could be built as open source. They're cool with that. 

* NEXT STEP ON OUR SIDE: let's discuss in our next cross-team call. Alongside other potential paths and options.

Comment 19

4 years ago
Sharing reflections from an email thread looking at StartUp Weekend. Can share more structured ideas as well. 

> * Every event organizer must previously attend an event. --> While this is probably too restrictive for our purposes, we should boost the event organizer trainings before Maker Party, and make it very strongly encouraged to attend them (virtual for sure, possibly some in person).

* 3rd party event pages. --> Looks like it's running a skinned version of Eventbrite. While 3rd party sites are great, we should map what we want that they don't / may not have. Including: MakeAPI integration, ability to contact all organizers and all participants, interoperability with other Mozilla event platforms (Reps, MDN, etc.), ability to clone or repeat events.

* Hackable yet united graphics. --> Many campaigns give you image templates you can adapt, like adding your city name, etc. We could do something similar, even putting the graphics into Thimble (a la Fuzzy's signature generator) for easy remixing: http://jsfiddle.net/rJ7Zt/107/

* Nobody has written good, tight event guides. --> Startup Weekend has theirs: http://startupweekend.org/organizer/organizers-guide/ but it's long and too proscriptive. This reflects what we see in lots of campaign sites. How do we give people good info while not overburdening?
(Reporter)

Comment 20

4 years ago
* In advance of today's cross-team call, want to figure out the best way to summarize what's been done on this ticket so far. And put some decisions and next steps in front of us so we don't lose momentum. 

Feels like the work divides into four different fronts:

1) EVENT BUGS WE WANT TO FIX *RIGHT NOW*
* These are problems or paint-points *not* blocked on us picking a future solution. They're fixes we believe can and should be made *now,* and we don't have to wait.  

2) FEATURE & FUNCTIONALITY REQUESTS
* Key requirements for what our new system needs to be. Amira and Michelle have roughly documented those above.

3) RESEARCH
* Specifically: a short-list of great *examples* of what *other* organizations are doing. Or working implementations in the field we can learn from or model after. 
* These can help us learn from others' successes, follow best practices, and not reinvent the wheel. 
* Again, many are listed above. Michelle: if you have others, please add asap.

4) GO-FORWARD OPTIONS
* Credible multiple choice options. Boil down all of the above into a short-list of potential paths we could take. With pros and cons for each.
(Reporter)

Comment 21

4 years ago
* NEXT STEPS ON THIS TICKET:

1) File and triage short-term bugs we want to fix now. From Amira's comment 15 above.
* we'll need some analysis on what's worth fixing now -- vs. what will have to wait for the new platform.

DALE: have these issues been filed already? Are you able to triage / assess / file these as separate bugs?

* a) fix confirmation when adding events. ability to click submit and know that your event has been processed (so people don't click and upload 100 times). 
* b) easier way to search events page. (search by term) and find events in an area
* c) see lists of upcoming events.
* d) give Amira ability to edit "email" and "created by" fields for events. So that she can create events for people, and then switch them over to someone else. 

2) Michelle will post some of her additional research here. 

3) Michelle will set up meeting w. Pierros. To further discuss MozReps platform possibilities. (noting Humph's big caveat about Django vs. Node.js)

Comment 22

4 years ago
Created attachment 8339348 [details]
EVENTS-paper-prototypes-1.0.png

Sharing some reference docs and research for previous work on events platform
(Reporter)

Updated

4 years ago
Flags: needinfo?(dale)
(Reporter)

Comment 24

4 years ago
Filtering through Michelle's links above to pull out other examples to look at: 

* 350.org http://local.350.org/ (open source -- here it is on Github) https://github.com/350org/localpower
* Controlshift http://www.controlshiftlabs.com/
* Mozilla Developer Network: Where is Mozilla? https://developer.mozilla.org/en-US/events
* Plancast.com http://plancast.com/
* Guestlistapp.com http://guestlistapp.com/
* Attendy https://www.atendy.com/
* City 2.0 http://www.thecity2.org/
* Space Apps Challenge: http://2013.spaceappschallenge.org/

Comment 25

4 years ago
Matt, I'll take care of filing/triaging that list by end of day (Wednesday), and I'll CC y'all on the bugs.
Flags: needinfo?(dale)

Comment 26

4 years ago
So a few of the bugs are a bit vague, could use a bit more info

* a) fix confirmation when adding events. ability to click submit and know that your event has been processed (so people don't click and upload 100 times). 
    - Is this related to the nothing happening when clicking Add an Event? I've still not encountered a bug where clicking Submit would add the event but not give a visual indicator. In my experience, if there was no 'Your event has been added' pop up after, then the event wasn't added.
* b) easier way to search events page. (search by term) and find events in an area
    - What do you mean by 'search by term'? Erika D filed a bug for finding events per area. However, this is adding new functionality & featured; right now, I think we need to focus on making what we have actually work as intended.
* c) see lists of upcoming events.
    - Filed @ https://bugzilla.mozilla.org/show_bug.cgi?id=944122
* d) give Amira ability to edit "email" and "created by" fields for events. So that she can create events for people, and then switch them over to someone else.
    - So would this be only a feature available to Webmaker administrators? Or is this available to any event owner? If I create an event as a normal user, should I have the ability to transfer ownership of that event? Amira would be able to potentially grab the userID which would make this easier but for normal users, I'm not sure if that would be a great idea? (privacy concerns). Also, I see this as being one field... changing the 'owner' would set the appropriate 'createdBy'/'email'.
Flags: needinfo?(matt)
(Reporter)

Comment 27

4 years ago
(In reply to Dale Karp (:daleee) from comment #26)
> So a few of the bugs are a bit vague, could use a bit more info
> 
> * a) fix confirmation when adding events. ability to click submit and know
> that your event has been processed (so people don't click and upload 100
> times). 
>     - Is this related to the nothing happening when clicking Add an Event?

* I believe so, yes.

> I've still not encountered a bug where clicking Submit would add the event
> but not give a visual indicator. In my experience, if there was no 'Your
> event has been added' pop up after, then the event wasn't added.

* Ok. Can you file this as a separate ticket and flag it as needinfo from Amira? She's back online Monday.


> * b) easier way to search events page. (search by term) and find events in
> an area
>     - What do you mean by 'search by term'? Erika D filed a bug for finding
> events per area. However, this is adding new functionality & featured; right
> now, I think we need to focus on making what we have actually work as
> intended.

* Ok, makes sense. Can you ensure Amira bas been CC'ed on whatever has already been filed on this? We can decide this particular feature request is resovled wontfix for now -- but good to have Amira weight in first.


> * c) see lists of upcoming events.
>     - Filed @ https://bugzilla.mozilla.org/show_bug.cgi?id=944122
> * d) give Amira ability to edit "email" and "created by" fields for events.
> So that she can create events for people, and then switch them over to
> someone else.
>     - So would this be only a feature available to Webmaker administrators?

Yes.

> Or is this available to any event owner?

No.

> Also, I see this as being one field... changing the 'owner' would
> set the appropriate 'createdBy'/'email'.

Makes sense. Sounds good. That should do it.
Flags: needinfo?(matt)

Comment 28

4 years ago
Hey y'all,

I filed bugs and CC'd everyone on them. Here they are:

Bug 944532 - Confirm existence of Add an Event breaking silently @ https://bugzilla.mozilla.org/show_bug.cgi?id=944532
Bug 891969 - Create a way to link to zoomed in area of the Events map @ https://bugzilla.mozilla.org/show_bug.cgi?id=891969
Bug 944535 - Allow Events admin to reassign event creator/user @ https://bugzilla.mozilla.org/show_bug.cgi?id=944535
(Reporter)

Updated

4 years ago
Whiteboard: [crossteambugs]
(Reporter)

Comment 29

4 years ago
@ Amira: now that you're back in the saddle, can you have a look at the examples in comment 25 above and see whether there's any that jump out as being good implementations for us to look at?
(Reporter)

Updated

4 years ago
Flags: needinfo?(amira)

Comment 30

4 years ago
(In reply to Matt Thompson (@OpenMatt :OpenMatt) from comment #24)
> Filtering through Michelle's links above to pull out other examples to look
> at: 
> 
> * 350.org http://local.350.org/ (open source -- here it is on Github)
> https://github.com/350org/localpower
> * Controlshift http://www.controlshiftlabs.com/
> * Mozilla Developer Network: Where is Mozilla?
> https://developer.mozilla.org/en-US/events

> * Plancast.com http://plancast.com/
- I like the more popular next month next week sorting at the top. Would make it easy to find upcoming events. 

> * Guestlistapp.com http://guestlistapp.com/
-this model has people register for the event directly on the page and then allows the owner of the page (and host) to collect participants contact info. Works well but we don't want to get into the business of people hosting registration on Webmaker as we will have to deal with potential ticket costs and active support. 

> * Attendy https://www.atendy.com/
-My friends made this site and I did a bunch of advising for them in their early stages. Again, it caters to people wanting to host event registration. The event pages are beautifully laid out https://www.atendy.com/event/tedxyorku-8705 but kind of biased as I consulted on the design :P

> * City 2.0 http://www.thecity2.org/
-like the incorporation of social feed and community highlights!

> * Space Apps Challenge: http://2013.spaceappschallenge.org/
-Not a fan of the map but the event pages look like a style-downed version of Atendy's
Flags: needinfo?(amira)
(Reporter)

Comment 31

4 years ago
* Summarizing from some email thread discussion:

* the key requirements discussion we need to have next for our events platform is around CRM. 
In terms of capturing data and communicating with event *organizers.* 
But also having a thesis for this for event *participants* as well. 

e.g., We think about 60,000 people attended Maker Parties this year.
Who are they? Where are they? How can we communicate with them? 

Next steps:
* discuss in cross-team call
https://webmaker.etherpad.mozilla.org/crossteam2
* but also: do research. how are *other* organizations managing this challenge? what tools and platforms are they using? 
* (e.g., 350.org, etc.)
(Reporter)

Updated

4 years ago
Blocks: 945881
No longer blocks: 945881
Depends on: 945881

Comment 32

4 years ago
Throwing in an example Karen shared of map/list view: https://openmedia.ca/ConnectedCanada#roll --> super cool integration of all (video, kits, text etc.)
(Reporter)

Comment 33

4 years ago
@ Kate: there's a lot of interesting design and UX research in the links above. Can help inform the work we were talking about today. 

* Let's close this ticket when you're ready, and file a new one for the ongoing events work?
Flags: needinfo?(kate)
Let's close this ticket and continue to file new ones the the events component.
Flags: needinfo?(kate)
(Reporter)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.