Closed Bug 93821 Opened 20 years ago Closed 20 years ago

Need noninteractive way to install Mozilla, and per-user plugins?

Categories

(SeaMonkey :: Installer, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 45699

People

(Reporter: hpa, Assigned: ssu0262)

Details

Downloading the tarball for Mozilla 0.9.x for Linux sets up a version without
Java, or other necessary plugins.  Unfortunately, the "download plugin" dialog
doesn't work in a root-installed environment running as a user -- it downloads
the plugin, and fails to install it with a cryptic message, since the user
doesn't have the appropriate permissions.

It seems to me that:

a) There needs to be a noninteractive method (RPM or tarball) to install a
complete functional browser, including plugins.  There may be such a method, but
if so, it isn't widely advertised.

b) It should be possible for a user to install "private" plugins, that would go
into their respective ~/.mozilla directory instead of in the global installation.
One can install a complete browser from rpm... one can then have a script copy
the NS4.x plugins into the plugins dir

And this is a duplicate of bug 45699

*** This bug has been marked as a duplicate of 45699 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
QA Contact: gemal → gbush
verified duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.