Closed Bug 938290 Opened 7 years ago Closed 5 years ago

Get a proper icon for the Shader Editor

Categories

(DevTools Graveyard :: WebGL Shader Editor, defect, P3)

28 Branch
defect

Tracking

(firefox41 fixed)

VERIFIED FIXED
Firefox 41
Tracking Status
firefox41 --- fixed

People

(Reporter: ntim, Assigned: ntim)

References

Details

(Whiteboard: [bugday-20150708])

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131112030204
The title says all :)
Component: Untriaged → Developer Tools: WebGL Shader Editor
OS: Windows 8.1 → All
Hardware: x86_64 → All
Blocks: 910955
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Flags: needinfo?(shorlander)
Flags: needinfo?(dhenein)
Flags: needinfo?(shorlander)
Did you manage to take a look at this, Darrin? No rush, just asking if this is still on your radar.
It IS on my radar, just a bit lower down the list. In the mean time, do you have any suggestions on what the icon could represent? This is essentially for vertex and frag shaders in WebGL, right?
Flags: needinfo?(dhenein)
(In reply to Darrin Henein [:darrin] from comment #3)
> It IS on my radar, just a bit lower down the list. In the mean time, do you
> have any suggestions on what the icon could represent? This is essentially
> for vertex and frag shaders in WebGL, right?

For now, yes :) More complex WebGL tooling might come to be in the future, but we can burn that bridge when we get there.

I'm thinking the icon could look like one or more pixelated interlaced triangles.
Flags: needinfo?(shorlander)
Attached image Shader Editor Icon — 01 (obsolete) —
What do you think about something like this?
Flags: needinfo?(shorlander) → needinfo?(vporof)
Nice! How about having a checkboard pattern on one half of the triangle? Then it's a nice metaphor: one half of the triangle symbolizes the vertex shader, the other half the pixel shader.
Flags: needinfo?(vporof)
Flags: needinfo?(vporof)
Nice!
Flags: needinfo?(vporof)
Stephen, can you provide an svg please ?
Flags: needinfo?(shorlander)
Attached image tool-shaderEditor.svg
I am not entirely sure how we are treating the Tool icons. Looks like one inverted icon with a filter for inverted icons? This might work as is, but I am not sure.
Flags: needinfo?(shorlander)
(In reply to Stephen Horlander [:shorlander] from comment #10)
> Created attachment 8611477 [details]
> tool-shaderEditor.svg
> 
> I am not entirely sure how we are treating the Tool icons. Looks like one
> inverted icon with a filter for inverted icons? This might work as is, but I
> am not sure.

This icon should work, thanks Stephen ! Yeah, we use an SVG filter to invert the icon in light theme.
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Attachment #8612103 - Flags: review?(bgrinstead)
Comment on attachment 8612103 [details] [diff] [review]
shader-editor-icon.patch

Review of attachment 8612103 [details] [diff] [review]:
-----------------------------------------------------------------

Pretty :)
Attachment #8612103 - Flags: review?(bgrinstead) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2a7773bb174f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Reproduced the bug in 28.0a1 (2013-11-13) on Linux x64

Verified as fixed with Latest Aurora 41.0a2 (2015-07-09)

Build ID: 20150709004007
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
QA Whiteboard: [bugday-20150708]
Whiteboard: [bugday-20150708]
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.