SVG text element font-size is ignored

RESOLVED DUPLICATE of bug 935056

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 935056
4 years ago
4 years ago

People

(Reporter: daniel.mcdougall, Unassigned)

Tracking

25 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20131113])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 831721 [details]
firefox_svg_text_size_bug.html

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.6 Safari/537.36

Steps to reproduce:

SVG text is being rendered HUGE.  It's as if the font-size style is being completely ignored.


Actual results:

The font is rendered HUGE and gets cut off as a result.  See the attached test case.


Expected results:

Text should be rendered nice and small and fit within the view without being cut off.

Comment 1

4 years ago
Think you talk about the letters "$ SSH" inside the little screen drawing

Seem to be correct with  
Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0

But i see the issue in Chromium	28.0.1500.71 (Build de développement 28.0.1500.71-0ubuntu1.13.04.1) Ubuntu 13.04

Comment 2

4 years ago
Daniel, please try this: open about:config and set svg.text.css-frames.enabled to "false".  If that helps, it's a duplicate of bug 935056.
Component: Untriaged → SVG
Product: Firefox → Core
Whiteboard: [bugday-20131113]

Comment 3

4 years ago
Sorry, I didn't check the actual "$ SSH" text.  I can reproduce it, and setting svg.text.css-frames.enabled to "false" helps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935056

Comment 4

4 years ago
I can confirm:  Setting svg.text.css-frames.enabled to "false" fixes the font size.  Definitely a duplicate of that other bug (which I didn't find when I searched, sorry).
You need to log in before you can comment on or make changes to this bug.