Common source comments spelling mistake - deprecated, not depricated

RESOLVED DUPLICATE of bug 106386

Status

--
trivial
RESOLVED DUPLICATE of bug 106386
18 years ago
2 years ago

People

(Reporter: neilconway, Assigned: neilconway)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

18 years ago
There is a common spelling mistake in the Mozilla source -- 'depricated' is used
instead of 'deprecated'.
(Assignee)

Comment 1

18 years ago
Created attachment 44757 [details] [diff] [review]
patch to fix spelling mistake

Comment 2

18 years ago
confirming.

Does this patch fix all occurences? If it does - then people might bother to
give it a quick review.

Also, it's convention to attach "diff -u" output, 
which is a bit easier for humans to read.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Spelling mistake - deprecated, not depricated → Common source comments spelling mistake - deprecated, not depricated
(Assignee)

Comment 3

18 years ago
Created attachment 44804 [details] [diff] [review]
unified patch to fix all instances of mistake
(Assignee)

Comment 4

18 years ago
I attached a new patch in unified diff format.

Yes, this patch does fix all the instances of the bug in the current CVS sources
(I searched using `grep`).

Thanks for the suggestions.

Comment 5

18 years ago
scott, I thought you'd like this one. 
Assignee: asa → scc

Comment 6

18 years ago
Careless greps yield 11 files (14 changes) in patch.
perhaps 22 (32 occurrences) in the mozilla tree?

warnings: security/nss is locked, js might have special rules.

general thought: when this is checked in, should we post to npm.<somethings> 
reminding people to correctly spell this word?

I wonder if we should teach lxr about deprecated :-)

I'd give an r= but i think i'll wait for other comments...
Assignee: scc → neilconway
Component: Browser-General → Tracking
Keywords: patch, review
QA Contact: doronr → scc
(Assignee)

Comment 7

18 years ago
WRT: additional files: Woops, I must have missed some (does 'make -f client
checkout' not checkout the entire tree?). I'll check that and upload a new patch
when I get a chance (or else someone else can, it's not exactly rocket science
;-) ).

Yeah, posting to n.p.m.? would probably be a good idea but I dunno which group
would be the best.

Thanks for the feedback.

Updated

17 years ago
Blocks: 106386

Comment 8

17 years ago
I sent the following to the reporter a whlie ago, i'm reproducing it here 
because someone asked me to address this bug. unfortunately, i'm typing 
blindly, so i'm not going to make any edits, just paste:

neilconway@home.com wrote:
> WRT: additional files: Woops, I must have missed some
you might have, or they might not have been there...
> does 'make -f client checkout' not checkout the entire tree?
it does not.  some parts of the tree (eg webtools) aren't necessary to mozilla 
browser development.
> I'll check that and upload a new patch when I get a chance
> (or else someone else can, it's not exactly rocket science ;-) ).
but it's so much fun

> Yeah, posting to n.p.m.? would probably be a good idea
> but I dunno which group would be the best.
hopefully someone will have ideas.

> Thanks for the feedback.
:-)

Comment 9

17 years ago
I just tried searching for depricated using LXR.  There are a zillion occurences
of MWJavaDoc_Proj_Depricated in macbuild xml files.  Is it possible to do a
global replace in Mozilla source replacing depricated with deprecated (since
there are _so_ many occurences?
Merged with bug #106386
No longer blocks: 106386
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 106386
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.