Closed Bug 938360 Opened 6 years ago Closed 2 years ago

[system update] Alcatel onetouch Fire to version 1.1 failed Poland

Categories

(Firefox OS Graveyard :: Vendcom, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: harloczek, Unassigned)

Details

(Keywords: dataloss, Whiteboard: [SUMO-b2g])

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

I downloaded and installed official update


Actual results:

All Contacts were deleted. I tried to import contacts from SIM and GMail, but it has failed. I tried to add contact manually, but it has faild also. So it's impossible to restore Contacts. I also received 1 very important SMS message that is unable to read. It's on my message list marke as 'unread' but it's unable to display.

I know that users from Poland have many other problems with new update.
Hello harl - Can you please confirm the build ID on your phone for me? You should be able to find this under device information.

What other problems have you heard about regarding this update?
QA Contact: mozillamarcia.knous
(In reply to Marcia Knous [:marcia - use needinfo] from comment #1)
> Hello harl - Can you please confirm the build ID on your phone for me? You
> should be able to find this under device information.

OS ver: 1.1.0.0
Firmware: 01012P
Hardware revision: 08
Platform version: 18.1

> 
> What other problems have you heard about regarding this update?

Permanent rebooting, displaying of window with message '[city name] 50'.
Severity: normal → major
Also, would be helpful to go to Device Information | System Update | Check for Updates and list the file name which appears there:

mine is Firefox OS 1.1.0.0-01012P
> mine is Firefox OS 1.1.0.0-01012P

As I wrote above, mine too.
My device is not working in mode USB mass storage after connection via cable. Before update I connected to backup docs from SD card.

Is anything new in this matter? I have no idea what to do because I sent a submission to my operrator T-Mobile. I'm enslaved with contract ;) I have to use hard reset and I'll lose all my data impossible to backup :(
I have another report of this in the SUMO forum today, confirming same issue with rebooting after update to v1.1 in Poland here:
https://support.mozilla.org/en-US/questions/977941


I also have a user in VE with TCL reporting the loss of contacts and broken contacts app after updating here (but not rebooting) this is Firefox OS 1.1.0.0 rev. 01061:
https://support.mozilla.org/en-US/questions/977924
And here is another one with lost contacts and broken contacts app from last night:
https://support.mozilla.org/en-US/questions/978003
Here are the larger number of reports from the mozilla-pl.org forum:
http://mozillapl.org/forum/viewtopic.php?f=38&t=45579
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [SUMO-b2g]
Flags: needinfo?(nhirata.bugzilla)
Putting QA Wanted to see if someone can reproduce this in house.
Keywords: qawanted
I did try this is one phone so far, although I think the hardware I have has something wrong with it - see Bug 938391

I am going to reflash a device with the 1.0.1, add some data, and see what happens.
Component: General → Gaia::Contacts
Here is another forum with a load of Polish posts, about half of them say the v1.1 update succeeds, the other half have a constantly rebooting device. http://forum.myfirefoxos.pl/watek-Aktualizacja-1-0-1-2P-jakie-wra%C5%BCenia-po-instalacji?pid=1362#pid1362

Apologies if this is now the wrong bug for reporting this.
Ok, I moved the rebooting issue to a new bug here: https://bugzilla.mozilla.org/show_bug.cgi?id=940743. Sorry about that.
Isn't bug 938564 the same as the contacts issue here? Also, I thought there was already some discussion going on about taking a patch for the contacts issue in 1.1, IIRC jsmith brought that up on a mailing list - or was that something else?
I've attached a log file from a TCL device in VE with this same issue.
Hi Jack, could you help to check logs from Comment#14 ? Thanks
Flags: needinfo?(liuyongming)
Sure, and it has been reproduced at local.
Flags: needinfo?(liuyongming)
Hi Michelle, i can't find any information about "contacts" from the "attachment 8335734 [details]", could please give me a "add contact manually" log, Thanks!
Hi Michelle, i can't find any information about "contacts" from the "attachment 8335734 [details]", could you please give me a "add contact manually" log, Thanks!
(In reply to harl from comment #2)
 
> OS ver: 1.1.0.0
> Firmware: 01012P
> Hardware revision: 08
> Platform version: 18.1

I have the same build but different hardware revision: 07

> Permanent rebooting, displaying of window with message '[city name] 50'.

'[city name] 50' - it is cell broadcast - http://en.wikipedia.org/wiki/Cell_Broadcast (Settings > Call Settings > Call broadcast service).

In my case constant rebooting is related to WiFi connection. When WiFi is on - I can work several *seconds* until reboot, when WiFi is off - several minutes.
Hi Michelle, could you help to check Comment#17 to see if it is possible to provide the logs?
Flags: needinfo?(mluna)
Hi Vance,

Sorry I missed this request, I saw comment 16 and thought this had been reproduced. I will ask the contributor to provide another log and try to get it back to you. I have also asked users reporting to take their device back to a store if it is possible for them.
Flags: needinfo?(mluna)
Attached file Poland build.prop
Since the update is pulled off; I can't seem to get the device to update in the states (Poland TCL device).
There's an upgrade tool : http://www.alcatelonetouch.com/global-en/support/download/one_touch_fire.html

Having said that it doesn't have any buttons to push to get the device updated to 1.1

The Poland 1.0.1 build is :
Gaia:     b3f6811f81406c453798c79c141550571fe4e732
Gecko:   
BuildID   20130703204736
Version   18.0
ro.build.version.incremental=52
Flags: needinfo?(nhirata.bugzilla)
I don't think this a Gaia/Contacts problem but a FOTA problem.
Yes, this bug is about the FOTA process itself.  
Moving to Vendcom as it is the FOTA server on the Vendors side.
Component: Gaia::Contacts → Vendcom
(In reply to Jose M. Cantera from comment #23)
> I don't think this a Gaia/Contacts problem but a FOTA problem.

(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #24)
> Yes, this bug is about the FOTA process itself.  
> Moving to Vendcom as it is the FOTA server on the Vendors side.

Why are you so sure about it's FOTA's problem?
Any Justification?
Sounds like comment 22 shows we've done what we could to try to reproduce this, but it won't work in the US. Removing qawanted - we should work with someone in country to establish reproducibility.
Keywords: qawanted
Per comment 16 It can be reproduced. But should flash in Vendor img.
Attached file CalldropAlcatel.rtf (obsolete) —
This is a log from the 1.1 acatel phone, details of build are in the file. The phone did not lock when on the phone.
Attachment #8346720 - Flags: review?(21)
Attachment #8346720 - Flags: feedback?
(In reply to rmcguigan from comment #28)
> Created attachment 8346720 [details]
> CalldropAlcatel.rtf
> 
> This is a log from the 1.1 acatel phone, details of build are in the file.
> The phone did not lock when on the phone.

Note - review? & feedback? flags are usually meant for reviewing patches, not information. If you want someone to look at this, I'd flag needinfo on them.
Comment on attachment 8346720 [details]
CalldropAlcatel.rtf

I don't know that much about OTA or FOTA. Alexandre has spent some time on it. Let's see if he can have a clue by looking at the log, and in the worst case redirect the question to someone else.
Attachment #8346720 - Flags: review?(21)
Attachment #8346720 - Flags: feedback?
This log is a pain to read, there is multiple adb logcat output mixed with device infos and copy/paste of OSX shell commands ...
E/GeckoConsole(  567): Content JS ERROR at app://communications.gaiamobile.org/dialer/js/telephony_helper.js:78 in errorCB: Unexpected error:  UnspecifiedError

This, however, sucks.
Flags: needinfo?(lissyx+mozillians)
(In reply to Alexandre LISSY :gerard-majax from comment #32)
> E/GeckoConsole(  567): Content JS ERROR at
> app://communications.gaiamobile.org/dialer/js/telephony_helper.js:78 in
> errorCB: Unexpected error:  UnspecifiedError
> 
> This, however, sucks.

What is the codebase of this device ? Seriously, I only see one errorCB at https://github.com/mozilla-b2g/gaia/blob/v1-train/apps/communications/dialer/js/telephony_helper.js#L46 for v1-train branch, line 78 is totally unrelated.
(In reply to rmcguigan from comment #28)
> Created attachment 8346720 [details]
> CalldropAlcatel.rtf
> 
> This is a log from the 1.1 acatel phone, details of build are in the file.
> The phone did not lock when on the phone.

Rachel, what issue should I be pursuing in this logcat mess ? I'd be happy to help but this bug report is a mess: subject is about vendor OTA failure, then messages reports issue about missing contacts, but there is nothing clear with it: what is the error message when contacts are failing ? Is it just that the lists are empty ? If it's the second case, then it might just be a buggy contacts db migration (I remember we fixed spurious cases) that makes contacts unavailable but everything is still in place.

Where is this debugging coming from ?
   4386 I/GeckoDump(  567): [communications] Checking if the call is to the VoiceMail...
   4387 I/GeckoDump(  567): [communications] The call is not to the VoiceMail
   4388 I/GeckoDump(  567): [communications] Retrieving icc.callmessage from Settings...
   4389 I/GeckoDump(  567): [communications] icc.callmessage retrieval successful:
   4390 I/GeckoDump(  567): [communications] Looking up contacts associated to phone number: "6505718167"

There is for sure no dump() call in the communications app on our side.

Etienne, can you confirm/have a look at the errorCB thing that I mentionned in the previous messages ? This really looks spurious to me.
Flags: needinfo?(rmcguigan)
Flags: needinfo?(etienne)
Did some research and I can confirm that at no point was the TelephonyHelper used in any upgrade code path.
So probably not the issue here :/
Flags: needinfo?(etienne)
Comment on attachment 8346720 [details]
CalldropAlcatel.rtf

Thought it helpful to have a successful call to compare it to. Putting as obsolete.
Attachment #8346720 - Attachment is obsolete: true
Flags: needinfo?(rmcguigan)
I think this may have something to do with bug 907444; I am not sure if locale on top of it is causing more of an issue for Poland build or not.   Since the Poland update is no longer available, we cannot reproduce it with a Poland version of the phone.  (we purchased one and tried to update in the states)
Dears, 

We have found one root reason of problem reported by harl, more details will be provided soon.
I found a situation can cause this problem, if a contact with no tel number exist in the contacts, upgrade the database will be wrong(from v1.0 to v1.1). 

All contacts in the original database will be  store  "tel": [***]   in the database, but the new database will not save this when the contact does not have a number, so we can not directly use 'tel.value' in ContactDB.jsm for contactDB upgrade ,we need to be judged.

I added a patch, please help to check if there are problems.
Thanks !

I had a quick look to your patch, and it smells quite like bug 862250, am I wrong?
Flags: needinfo?(wuww)
Flags: needinfo?(liuyongming)
(In reply to Alexandre LISSY :gerard-majax from comment #40)
> Thanks !
> 
> I had a quick look to your patch, and it smells quite like bug 862250, am I
> wrong?

That patch have merge to 1.1,I make changes based on it.
Flags: needinfo?(wuww)
Oh sorry, you're right, I misread.
Flags: needinfo?(liuyongming)
Was this fixed and did a new update ever go out in Poland?
I think it's fixed and you can close this bug.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.