Lightning with Kerio (CalDAV) does not send mail notification to participants

RESOLVED WORKSFORME

Status

Calendar
Provider: CalDAV
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: forum.news, Unassigned)

Tracking

Lightning 2.6.2

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

I have a caldav calendar hosted on a Kerio server. It used to work OK but since a couple a weeks, I cannot add participants to an appointment anymore. I can add them, but no notification mail is sent to them. The checkbox "notify participants" is checked, but disabled. No popup appears if I want to send a notification.


Actual results:

As mentioned: The participants added to an appointment do not get a notification mail.


Expected results:

A notification mail should be send to each participant.
(Reporter)

Comment 1

5 years ago
More information:

I found out that it works OK as long as you use your "real" mail account address. If you use an alias as mail address, it does not work anymore. In addition to the above described issue, Lightning (or Kerio) sends me a "declined" mail for my own calendar entries if I delete them. I think that is also caused by the alias because it cannot tell that I'm the owner of the appointment.

btw: How is responsible for sending the notification mail? Is it the client (Lightning) or is it the server (Kerio) in this scenario?

Konrad

Comment 2

4 years ago
I'm also using Kerio Connect (8.2.1) here and everthing's working fine.
In my case, the identity set up in calendar properties is simply being ignored. Kerio itself sets the calendar owner as the organizer. Invitations and responses are being sent from Kerio internal, but leaving a sent message in the calendar owners Sent folder.

I have not yet tested using a calendar without having the corresponding Mail address configured somewhere in Thunderbird. Maybe it helps, that you configure your "real" mail address as another identity in your account settings?
(Reporter)

Comment 3

4 years ago
It started working again with v2.6.3. So, my guess is that this was a bug in 2.6.2. But now, "normal" caldav calendars are not working anymore :-(. Same issue... So I went back to 2.6.0...

Konrad
Some CalDAV problems were fixed in 2.6.4, maybe give it a try: https://addons.mozilla.org/thunderbird/addon/lightning/versions/2.6.4
(Reporter)

Comment 5

4 years ago
Yes, just did a quick check and seems to work again with my caldav server.

Thx
Konrad
Resolving as WORKSFORME per comment#5. Feel free to re-open this issue if the problem occurs again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.