FirefoxOS page on mozilla.org is not redirected to https

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: arroway, Unassigned)

Tracking

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/186] )

Assignee: nobody → ptheriault
Component: Security Assurance → Gaia
Product: mozilla.org → Firefox OS
Version: other → unspecified
Stéphanie, this is a gaia concern right? Can you make this bug block the review bug (or link the wiki secreview related to this). 

Can you elaborate a little on your concerns too? From memory the issue was having http link hardcoded in code, when https versions were available - is that correct?
Flags: needinfo?(stephouillon)
How is this related to Gaia exactly? Can I get clear STR here?
(Reporter)

Comment 3

5 years ago
Paul, it is not related to Firefox OS at all. It's something I noticed on desktop, it is IT related (https redirection as set on the web server) as I intended to specify in the product/component description. So I'll move it back, if it's not good at least it will not mislead to FirefoxOS!
Flags: needinfo?(stephouillon)
(Reporter)

Comment 4

5 years ago
Well, I can't change it back to what I want, I guess you'll be able to.

Updated

5 years ago
Component: Gaia → General
Product: Firefox OS → www.mozilla.org

Updated

5 years ago
Assignee: ptheriault → nobody

Updated

5 years ago
Assignee: nobody → server-ops-webops
Component: General → WebOps: SSL and Domain Names
Product: www.mozilla.org → Infrastructure & Operations
QA Contact: nmaul
Version: unspecified → other
Component: WebOps: SSL and Domain Names → WebOps: Product Delivery
this would require adding a http->https redirect across the entire bedrock (www) service. we do something similar across other projects, but i'd like to tread carefully with this in production to avoid causing mixed content issues this may cause for people linking to the site. i am going to wrap in a couple of the bedrock developers for their thoughts here.
Flags: needinfo?(pmac)
Flags: needinfo?(jmize)
OS: Linux → All
Hardware: x86_64 → All

Updated

5 years ago
Depends on: 358384
Flags: needinfo?(jmize)
Is there a reason this page in particular needs to be HTTPS more than others? We can force individual pages in the bedrock code, but we're only doing that as needed until we fix the issues preventing us from making the site fully HTTPS only (which is bug 358384 as :jgmize added).
Flags: needinfo?(pmac)
(Reporter)

Comment 7

5 years ago
When I noticed that, it was because these URLs were (and still are) hardcoded in gaia builds. It has waited until now, so I guess it can wait a little bit more for bug 358384 to be resolved.

Updated

4 years ago
No longer depends on: 358384

Updated

4 years ago
Depends on: 796109
Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/186]

Comment 8

4 years ago
Fixed!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.