Add Google Analytics to BSD donation (sendto) pages

RESOLVED FIXED

Status

Websites
donate.mozilla.org
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: secretrobotron, Assigned: secretrobotron)

Tracking

Details

(Assignee)

Description

4 years ago
GA is missing from several important BSD donation pages (sendto.mozilla.org):

https://sendto.mozilla.org/page/contribute/EOYFR2013-snippetEN
https://sendto.mozilla.org/page/contribute/EOYFR2013-tabzilla
https://sendto.mozilla.org/page/contribute/EOYFR2013-privacy-trust
https://sendto.mozilla.org/page/contribute/join-mozilla

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-35433268-5']);
  _gaq.push(['_trackPageview']);
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>
(Assignee)

Updated

4 years ago
Component: WebOps: Other → donate.mozilla.org
Product: Infrastructure & Operations → Websites
QA Contact: nmaul
Need to check with Winston and Alex F to make sure we're not going to ruffle too many feathers. Apparently during last year's campaigns a Reddit thread blew up because we were using google analytics on the donation pages. :(
Legal is a green light for Google Analytics:

Hi Andrea,

That seems fine to me.  Google Analytics offers an opt-out that we describe in our privacy policy (see below) and we switched to GA because they offered us the ability to opt-out of the use of our data for any other purpose.  I sent Chris More a note just in case he can think of anything we may be missing, but otherwise, I'd say let's go ahead and put it back on.

Opt-out Procedures

If you do not want data about your visits to Mozilla websites to be collected by Google Analytics, you can install the Google Analytics Opt-out Browser Add-on. The add-on keeps your visits anonymous and prohibits any data from being sent to Google Analytics. Additionally, if you signed up to receive but no longer wish to receive electronic marketing communications from Mozilla, you can opt-out from receiving these communications by following the “unsubscribe” instructions in any such communication you receive.


From: "Andrea Wood" <andrea@mozillafoundation.org>
To: "Stacy Martin" <smartin@mozilla.com>
Cc: "Alex Fowler" <afowler@mozilla.com>, "Winston Bowden" <wbowden@mozilla.com>, "Geoffrey MacDougall" <geoffrey@mozillafoundation.org>
Sent: Monday, November 18, 2013 10:49:55 AM
Subject: Re: Google Analytics

hi Stacy! Geoffrey's out so I just wanted to check in on whether you could give us direction on Google Analytics implementation on mozilla.org?

Thanks so much,

Andrea
___

Andrea Wood
Online Organizing & Fundraising Lead
Mozilla

[v] (510) 922-0181

skype: valiant_try
gchat:  andrealw
blog:    valianttry.us




On Nov 15, 2013, at 11:30 AM, Geoffrey MacDougall <geoffrey@mozillafoundation.org> wrote:

Stacy: We pulled the plug on all analytics during StopWatching.Us as a
bit of a pre-emptive move. Can we put Google Analytics back? It will
help us run the EOY campaign, test, etc.

On Fri, Nov 15, 2013 at 2:30 PM, Alex Fowler <afowler@mozilla.com> wrote:
Punting over to Stacy, who has done the lion share of work on use of GA.


On 11/15/13 11:11 AM, Geoffrey MacDougall wrote:

Cool. Thanks, Winston.

Alex?

On Fri, Nov 15, 2013 at 2:09 PM, Winston Bowden <wbowden@mozilla.com>
wrote:

No reason we can't from my perspective.  Google Analytics is implemented
across Moz.org.


On 11/15/13 8:34 AM, Geoffrey MacDougall wrote:

Hi All,

If you recall, we stripped all the analytics out of the donation page
during StopWatching.Us due to the optics.

We'd love to be able to put Google Analytics back on that page.

Any reason we can't? Thoughts?

Thanks,

G.


--
Winston Bowden
Sr. Manager, User Engagement
Mozilla
wbowden@mozilla.com
Twitter @winstonbowden
www.mozilla.com






-- 
Stacy Martin
Senior Manager, Privacy and Engagement
Mozilla
2 Harrison Street, Suite 700, San Francisco, CA
916-390-4845 (cell)
stacy@mozilla.com

Comment 4

4 years ago
The GA code in comment 0 is the correct GA code for sendto.mozilla.org. GA is already on sendto.mozilla.org already as I have data already in GA. The page hit the most is /page/s/sign-up-for-mozilla and is already on all of the pages mentioned above.
Hi Chris--

We noticed GA is not on several key pages, including the correct donation landing page we've been using for a while (https://sendto.mozilla.org/page/contribute/join-mozilla). I think it may have been removed from a few key pages in the wake of the SWU kurfuffle, and now we're just adding it on those pages, and also on new donation landing pages we're creating for the campaign. 

(In reply to Chris More [:cmore] from comment #4)
> The GA code in comment 0 is the correct GA code for sendto.mozilla.org. GA
> is already on sendto.mozilla.org already as I have data already in GA. The
> page hit the most is /page/s/sign-up-for-mozilla and is already on all of
> the pages mentioned above.
(Assignee)

Comment 6

4 years ago
Confirmed GA added to all EOYFR2013 pages (was added in the wrapper template). Just added it to join-mozilla as well.

Andrea, any other sites we should double-check?
Flags: needinfo?(andrea)
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

4 years ago
Discussed with Andrea. Everything is in place for now.
Flags: needinfo?(andrea)
You need to log in before you can comment on or make changes to this bug.