Closed Bug 938777 Opened 11 years ago Closed 6 years ago

With the language set to German the privacy policies and terms remain in English

Categories

(Core Graveyard :: Identity, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: vikas.nanda, Unassigned)

References

Details

Attachments

(5 files)

Attached image 2013-11-14-21-38-24.png
steps to reproduce:
1. Start MP stage in German language. 
2. Select settings. 
3. Select sign up. 
4. Select any of the 4 links (privacy policy/terms) for personas or marketplace.allizom.org

expected behavior:
Each of the terms and polices should load in the German language. 

observed behavior:
The terms and polices load in English.
Attached image 2013-11-14-21-39-04.png
Attached image 2013-11-14-21-39-27.png
Attached image 2013-11-14-21-41-40.png
Please check again: http://cl.ly/image/3H330z1r1y2O

Stage was not updated until this morning.
Hi Christopher, I have flashed the device and all 4 sections are still appearing in English for me.
Component: Payments/Refunds → Consumer Pages
Fixed:

https://github.com/mozilla/fireplace/commit/79c3130c886d6f49fb09fa536acd6a67d98b8a98

We need to remember to update marketplace.js for the jank hack because Persona.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Attached image Privacy and persona.png
Privacy and persona is still displaying in English.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This change goes into production on Tuesday.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
(In reply to Matt Basta [:basta] from comment #9)
> This change goes into production on Tuesday.

The tester is in on stage and should be able to see these changes.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
"Privacy & Persona"? Where does this document live? I'm not familiar with it, and I can't search for it in zamboni or webpay. Andy? Kumar?
https://github.com/mozilla/zamboni/tree/master/media/docs

I can't reproduce this on -dev or stage. When I set the browser language to German and open Persona, the links all point to the german version of the docs. Prod is the only place I can reproduce, for obvious reasons.

If this is indeed persisting on stage, I'll need logs to debug it further.
Flags: needinfo?(vikas.nanda)
Basta, look at the screenshot: https://bug938777.bugzilla.mozilla.org/attachment.cgi?id=8336921

It's not even of our Privacy Policy. "Privacy & Persona" that text I can't find.
Oh. That's not ours. That's a Persona document:

https://login.persona.org/en/embedded_privacy

Moving this over to Identity.
Component: Consumer Pages → Identity
Flags: needinfo?(vikas.nanda)
Product: Marketplace → Core
Version: 1.1 → unspecified
Looks like a persona issue. i'll file a github issue.
Yup, confirmed; thanks for the report.  Let's take the discussion to the github issue krupa files.
We need Legal's help in getting German translations.  (Legal does not wish for us to source these translations from contributors.)

I've opened bug 947995
The persona tos/pp issue is also being tracked by your bug 943295.  Do you want to close this or dupe the other?
See https://bugzilla.mozilla.org/show_bug.cgi?id=1497358; closing remaining open bugs in this component.
Status: REOPENED → RESOLVED
Closed: 11 years ago6 years ago
Resolution: --- → INCOMPLETE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: