Firefox crash if I use the caldavzap web application

RESOLVED DUPLICATE of bug 844819

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 844819
4 years ago
4 years ago

People

(Reporter: Ludovic Rousseau, Unassigned)

Tracking

({crash})

25 Branch
x86_64
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
If I go to http://www.inf-it.com/caldavzap/‎ then Firefox crashes after a few seconds.

I can reproduce the problem using my own copy of caldavzap.
(Reporter)

Comment 1

4 years ago
The crash details are:

AdapterDeviceID: 0x944a
AdapterVendorID: 0x1002
Add-ons: https-everywhere%40eff.org:3.4.2,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:25.0,%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D:2.4,en-gb%40flyingtophat.co.uk:1.19.5,jid1-ZAdIEUB7XOzOJw%40jetpack:0.3.8,firefox%40ghostery.com:5.0.6
BuildID: 20131025151332
CrashTime: 1384467323
EMCheckCompatibility: true
InstallTime: 1383213547
Notes: AdapterVendorID: 0x1002, AdapterDeviceID: 0x944aGL Layers! GL Context? GL Context+ GL Layers+ xpcom_runtime_abort(###!!! ABORT: Attempt to create unsupported SourceSurface fromnon-image surface.: file /builds/slave/rel-m-rel-osx64_bld-0000000000/build/gfx/thebes/gfxPlatform.cpp, line 732)
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 415
StartupTime: 1384467305
Theme: classic/1.0
Throttleable: 1
URL: http://www.inf-it.com/caldavzap/
Vendor: Mozilla
Version: 25.0

Ce rapport contient également des informations techniques sur l'état de l'application lors du plantage.

If started from a terminal I also have:
Nov 14 23:16:25 iMac-de-Ludovic.local firefox[3175] <Error>: CGImageCreate: invalid image size: 0 x 0.
###!!! ABORT: Attempt to create unsupported SourceSurface fromnon-image surface.: file /builds/slave/rel-m-rel-osx64_bld-0000000000/build/gfx/thebes/gfxPlatform.cpp, line 732
###!!! ABORT: Attempt to create unsupported SourceSurface fromnon-image surface.: file /builds/slave/rel-m-rel-osx64_bld-0000000000/build/gfx/thebes/gfxPlatform.cpp, line 732
(Reporter)

Comment 2

4 years ago
I do not have the problem using the beta version 26.0b4.
Maybe it is an already known and fixed bug.
Please load about:support and copy the information in the Graphics section here (using the version that crashes).
Component: General → Graphics
Keywords: crash
Product: Firefox → Core
(Reporter)

Comment 4

4 years ago
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 1,
    "windowLayerManagerType": "OpenGL",
    "windowLayerManagerRemote": true,
    "adapterDescription": "",
    "adapterVendorID": "0x1002",
    "adapterDeviceID": "0x944a",
    "adapterRAM": "",
    "adapterDrivers": "",
    "driverVersion": "",
    "driverDate": "",
    "webglRenderer": "ATI Technologies Inc. -- ATI Radeon HD 4850 OpenGL Engine",
    "info": {
      "AzureCanvasBackend": "quartz",
      "AzureSkiaAccelerated": 0,
      "AzureFallbackCanvasBackend": "none",
      "AzureContentBackend": "quartz"
    }
  },

Comment 6

4 years ago
Given that this page uses SVG, the reading of bug 936087, then you saying it's fixed in 26 and bug 844819 is indeed fixed in 26, I'll call this a duplicate.

Thanks for reporting, though, it's better finding a duplicate than ignoring an issue and never get it filed. :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 844819
You need to log in before you can comment on or make changes to this bug.