Unable to run a subset of xpcshell tests for Android

RESOLVED DUPLICATE of bug 945975

Status

RESOLVED DUPLICATE of bug 945975
5 years ago
10 months ago

People

(Reporter: gbrown, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
config/makefiles/xpcshell.mk had support for running subsets of xpcshell tests on Android via:

make -C <dir> xpcshell-tests-remote
SOLO_FILE=<test> make -C <dir> check-one-remote

But xpcshell.mk was deleted by bug 901990. We can still run *all* the tests via make xpcshell-tests-remote (supported by testsuite-targets.mk) but cannot restrict to only a directory or only a single test.

AFAIK, there's no mach support for Android tests yet (that's kind-of on my todo list). 

I think this loss of functionality was accidental.
I think the best way to fix this would be to wire up a mach command, even if it's not perfect. We'll get a lot more mileage out of that than out of trying to hack the old makefile targets back in.
(Reporter)

Comment 2

5 years ago
We can do this with mach now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 945975

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.