All users were logged out of Bugzilla on October 13th, 2018

Spellcheck crash in 0.9.3

VERIFIED WONTFIX

Status

P2
major
VERIFIED WONTFIX
17 years ago
10 years ago

People

(Reporter: fswanepoel, Assigned: kinmoz)

Tracking

({crash})

Trunk
mozilla0.9.5
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Removed Mozilla 0.9.2 from system
Installed mozilla 0.9.3. (mozilla-i686-pc-linux-gnu-0.9.3-sea.tar.gz)
Opened browser to file://path-to-NS6.1/xpi/spellchecker.xpi
This installed the spellchecker succefully:
From install.log
file:///mnt/shared/browsers/netscape6/netscape-installer/xpi/spellchecker.xpi  -
-  08/06/2001 13:50:31
-------------------------------------------------------------------------------

     Netscape Spell Checker
     ----------------------

     ** initInstall: 0
     ** communicatorFolder: /usr/local/mozilla/
     ** addDirectory() returned: 0
     [1/4]      Create Folder: /usr/local/mozilla/components/spellchecker
     [2/4]      Installing: /usr/local/mozilla/components/spellchecker/pen4s324.
dat
     [3/4]      Installing: /usr/local/mozilla/components/spellchecker/netscape.
dic
     [4/4]      Installing: /usr/local/mozilla/components/spellchecker/libspellc
hk.so

     Install completed successfully
     ** performInstall() returned: 0
     Finished Installation  08/06/2001 13:50:32


When running the spell checker mozilla crash with the following error:
/usr/local/mozilla/mozilla-bin: error while loading shared libraries:
/usr/local/mozilla/components/spellchecker/libspellchk.so: undefined symbol:
StartAssignmentByValue__14nsXPIDLCString


This worked in 0.9.2

Thanks for your attention
Regards 
Francois

Comment 1

17 years ago
Have a look at bug 56301
I don't think the netscape spell checker xpi works any more. A different spell
checker is being considered for mozilla (open sourced).
reassign to editor who own the spellcheck
Assignee: ducarroz → beppe

Comment 3

17 years ago
assigning t kin to confirm crash
Assignee: beppe → kin
Severity: normal → major
Keywords: crash
Priority: -- → P2
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 4

17 years ago
Looks like a link problem.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

17 years ago
I wonder if the Netscape6.1 product had some string changes that aren't in 
mozilla 0.9.3 (or vice versa).
(Assignee)

Comment 6

17 years ago
-> 0.9.5

FYI, this does not happen in Netscape Commercial builds based on the TRUNK. I
think brade may be correct. There might be some xpcom/string changes in 0.9.3
that aren't in the libraries used for Netscape 6.1.
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 7

17 years ago
Ispell backend?
I know there are some licensing problems with spell checkers & Mozilla. Why not
using ispell on Unix systems? Doing execvp() on ispell won't break any license,
and will provide easy spell checking, and with a common dictionnary shared by
many other programs.
(Assignee)

Comment 8

17 years ago
Marking this WONTFIX, since at the moment we aren't making any guarantees about 
backward compatibility with libraries from previous versions.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 9

17 years ago
verified so
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.