If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP] In editor, copy/paste text to Body causes crash

VERIFIED WORKSFORME

Status

()

Core
Editor
P2
critical
VERIFIED WORKSFORME
19 years ago
16 years ago

People

(Reporter: fenella, Assigned: Stuart Parmenter)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Linux (1999-07-07-08 m8)
Summary: [PP] In compose window, copy and paste text to Body causes crash
Steps to reproduce:
1. From Messenger, click on New Msg to open the Compose window
2. Fill in the To: and Subject fields
3. High-light the text from the Subject field
4. Press on both the left and right mouse simultaneously
Actual result, apprunner crashes
Expected result: In Nova, this pastes the high-lighted text to the Body of the
Compose window. I expect seamonkey does the same like Nova. Even if it does not,
it should not crash.
This occurs to Linux only

Here is the stack trace:

(gdb) where
#0  0x40197d78 in nsClipboard::GetNativeClipboardData ()
#1  0x401a63ad in nsBaseClipboard::GetData ()
#2  0x40cfe0d9 in nsEditor::Paste ()
#3  0x40d07f88 in nsTextEditor::Paste ()
#4  0x40d1830c in nsHTMLEditor::Paste ()
#5  0x40d14b7e in nsTextEditorMouseListener::MouseDown ()
#6  0x408b2914 in nsEventListenerManager::HandleEvent ()
#7  0x409eb980 in nsDocument::HandleDOMEvent ()
#8  0x4090b57b in nsHTMLHtmlElement::HandleDOMEvent ()
#9  0x409f7072 in nsGenericElement::HandleDOMEvent ()
#10 0x408f53c7 in nsHTMLBodyElement::HandleDOMEvent ()
#11 0x408dbf30 in PresShell::HandleEvent ()
#12 0x40acc7bd in nsView::HandleEvent ()
#13 0x40acc777 in nsView::HandleEvent ()
#14 0x40acc777 in nsView::HandleEvent ()
#15 0x40acc777 in nsView::HandleEvent ()
#16 0x40ad3fad in nsViewManager::DispatchEvent ()
#17 0x40acb26e in _init ()
#18 0x401a1f26 in nsWidget::DispatchEvent ()
#19 0x401a1e7d in nsWidget::DispatchWindowEvent ()
#20 0x401a1fa3 in nsWidget::DispatchMouseEvent ()
#21 0x401a268c in nsWidget::OnButtonPressSignal ()
#21 0x401a268c in nsWidget::OnButtonPressSignal ()
#22 0x401a2a27 in nsWidget::ButtonPressSignal ()
#23 0x80c4748 in gtk_window_set_default_size ()
#24 0x809d5a3 in gtk_signal_connect_object ()
#25 0x809cc2a in gtk_signal_connect_object ()
#26 0x809b366 in gtk_selection_data_set ()
#27 0x80bce90 in gtk_widget_size_request ()
#28 0x80864e5 in gtk_get_current_event ()
#29 0x8085a86 in gtk_main_iteration_do ()
#30 0x80d415b in gdk_input_add ()
#31 0x80e70e0 in g_list_length ()
#32 0x80e755b in g_list_length ()
#33 0x80e7675 in g_main_iteration ()
#34 0x808559b in gtk_main ()
#35 0x401977a3 in nsAppShell::Run ()
#36 0x400fe16a in nsAppShellService::Run ()
#37 0x8052406 in main ()
(gdb) q

compose window.

Comment 1

19 years ago
Good find.  Does this occur in the Editor (not mail compose)?  cc: sspitzer.
(Reporter)

Comment 2

19 years ago
This occurs in the mail composer

Comment 3

19 years ago
Also, is this HTML or plain text mail compose?
(Reporter)

Comment 4

19 years ago
Yes. The same crash and same stack trace occurs when I do a copy and paste in
the editor.

Steps to reproduce:
1. Run apprunner
2. From the Tasks menu, select Editor to open an Ender page
3. Type a line of text
4. High-light part of the text
4. Press on both the left and right mouse simultaneously, the same crash happens

Updated

19 years ago
Assignee: phil → buster
QA Contact: lchiang → sujay
Summary: [PP] In compose window, copy/paste text to Body causes crash → [PP] In editor, copy/paste text to Body causes crash

Comment 5

19 years ago
Reassign to buster in Ender group. Set Sujay to QA contact.

Updated

19 years ago
Assignee: buster → akkana
Component: Back End → Editor
Priority: P3 → P2
Product: MailNews → Browser

Comment 6

19 years ago
assigned to akkana

Updated

19 years ago
Assignee: akkana → pavlov

Comment 7

19 years ago
Pavlov had a crash in clipboard code which he fixed today.  Pav, is this the
crash you were talking about?  Fenella, you might want to try again with
Thursday's build and see if it's fixed.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

19 years ago
this works for me.  marking it as so.  i'm guessing it was my clipboard breakage
on that day.

Comment 9

18 years ago
FEnella, please verify when you get chance..thanks!
QA Contact: sujay → fenella
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

18 years ago
Linux (1999-07-14-16 m8)
I followed the 4 steps as described.  There is no more crash.
You need to log in before you can comment on or make changes to this bug.