CSS "overflow:scroll" and "overflow:hidden" fails

RESOLVED WORKSFORME

Status

()

Core
CSS Parsing and Computation
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Wolfgang Grinfeld, Assigned: David Hyatt)

Tracking

({testcase})

Trunk
Future
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
If HTML or XUL uses the style elements overflow:hidden or overflow:scroll , the
page does not clip or allow to scroll the clipped part
(Reporter)

Comment 1

17 years ago
Created attachment 44789 [details]
XUL test page
(Reporter)

Comment 2

17 years ago
Created attachment 44791 [details]
testcase #2
Over to XUL. seeing this on linux build 2001-08-06-08 too
Assignee: asa → trudelle
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Toolkit/Widgets: XUL
Ever confirmed: true
OS: Windows NT → All
QA Contact: doronr → jrgm
CSS problem
Assignee: trudelle → pierre
Component: XP Toolkit/Widgets: XUL → Style System
QA Contact: jrgm → ian

Comment 5

17 years ago
Created attachment 44993 [details]
similar testcase in html

Comment 6

17 years ago
A similar testcase converted to html fixes some of the problems but not all 
(especially overflow:hidden).  Reassigned to hyatt like bug 42492 but maybe both 
bugs should go to evaughan like bug 34031.
Assignee: pierre → hyatt
(Reporter)

Comment 7

17 years ago
In HTML, note the caret moving on the screen when entering data on a clipped
input box
overflow: hidden is covered by the old bug 46257, assigned to buster; I'll toss
that to hyatt.
Just because this bug is related to a CSS property doesn't mean it's in the 
Style System.  This bug is in block Layout.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 10

16 years ago
*** Bug 108332 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
Regarding comment #9 should this be moved to layout now?
Keywords: mozilla1.2, testcase

Comment 12

16 years ago
wfm moz 2002101508 win98
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.