[gaiatest] [settings] test_settings_do_not_track.py is failing

RESOLVED DUPLICATE of bug 938707

Status

RESOLVED DUPLICATE of bug 938707
5 years ago
5 years ago

People

(Reporter: askeing, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gaia-ui-test])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
TEST-START test_settings_do_not_track.py
test_enable_do_not_track_via_settings_app (test_settings_do_not_track.TestSettingsDoNotTrack)
Enable do not track via the Settings app ... ERROR

======================================================================
ERROR: None
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.6.2-py2.7.egg/marionette/marionette_test.py", line 143, in run
    testMethod()
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_do_not_track.py", line 26, in test_enable_do_not_track_via_settings_app
    do_not_track_settings.tap_disallow_tracking()
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/do_not_track.py", line 26, in tap_disallow_tracking
    el = self.marionette.find_element(*self._disallow_tracking_checkbox_locator)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.6.2-py2.7.egg/marionette/marionette.py", line 1100, in find_element
    response = self._send_message('findElement', 'value', **kwargs)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.6.2-py2.7.egg/marionette/marionette.py", line 577, in _send_message
    self._handle_error(response)
  File "/var/lib/jenkins/jobs/B2G.master.pvt.hamachi.gaiatest/workspace/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.6.2-py2.7.egg/marionette/marionette.py", line 598, in _handle_error
    raise NoSuchElementException(message=message, status=status, stacktrace=stacktrace)
TEST-UNEXPECTED-FAIL | test_settings_do_not_track.py test_settings_do_not_track.TestSettingsDoNotTrack.test_enable_do_not_track_via_settings_app | NoSuchElementException: Unable to locate element: //li/label[span[@data-l10n-id="doNotTrackActions"]]
----------------------------------------------------------------------
Ran 1 test in 56.994s
(Reporter)

Updated

5 years ago
Whiteboard: [gaia-ui-test]
(Reporter)

Comment 1

5 years ago
Created attachment 832827 [details] [review]
PR 13736
Attachment #832827 - Flags: review?(bob.silverberg)
Sorry, Askeing, but I already fixed this yesterday in bug 938707.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938707
Attachment #832827 - Flags: review?(bob.silverberg)
You need to log in before you can comment on or make changes to this bug.