Remove the Reset button!

RESOLVED FIXED in Bugzilla 2.16

Status

()

P2
normal
RESOLVED FIXED
18 years ago
6 years ago

People

(Reporter: brendanb, Assigned: myk)

Tracking

2.13
Bugzilla 2.16

Details

(Reporter)

Description

18 years ago
Since the dawn of HTML/2.0 (or whenever the FORM tag appeared), people have been
adding that worthless and destructive button next to the Submit button on EVERY
form I see.  As the maintainer of RPGBoard, a message board script, it was one
of the first things I removed, as the pain of clearing away an hour's worth of
typing was enough to start bitching at the one who put the button there.

Let's start/continue a trend and remove it here!
That button exists for a reason though.  If I really screw up a query and want to 
start over, the button is a heck of a lot faster than reloading the page when I'm 
on a 28K dialup connection. :-)

How about if we move it further away from the Submit button so it's not so easy 
to hit it on accident?

Comment 2

17 years ago
Presumably the HTML 2.0 spec does not prohibit a browser from providing an undo 
action for a reset button, or otherwise insist that performing a reset be 
irrevokable.

It seems strange that (at least in MSIE5.0) I can undo every edit on a form 
_except_ accidentally pressing Escape or clicking on the "Reset" button. 
Perhaps what is really required here is an enhancement to the browser to allow 
the reset action to be undone.
(Reporter)

Comment 3

17 years ago
> That button exists for a reason though.  If I really screw up a query and want 
> to start over, the button is a heck of a lot faster than reloading the page when 
> I'm on a 28K dialup connection. :-)

Lemme put in this way:

Number of times I -WANTED- to use the Reset button: 2
Number of times I accidently hit the Reset button: 22

Yes, I think that an undo function would work great, but it's just not there. 
Frankly, I think an undo function on FORMs on all browsers should work exactly
like most advanded text editors.  Put in an undo buffer, up to about 5-10
actions, including hitting the Reset button.
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.16

Comment 4

17 years ago
-> New Bugzilla Product
Assignee: justdave → myk
Component: Bugzilla → User Interface
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → 2.13
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18

Comment 6

17 years ago
While I don't strong disargee...come on, guys!  This is just a removal of one
line :)

I tell you what.  Somebody point out the file, and I'll make a patch for it.  I
can relate to the request to keep the button, so something like this would work:

[tr]
   [td align=left][Commit button][/td]
   [td align=right][Reset button][/td]
[/tr]

So, it would look like this:

[Commit]                                                                 [Reset]

Not too ugly and serves its purpose.
This was fixed as a result of the patch checked in on bug 98707.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Depends on: 98707
Resolution: --- → FIXED

Comment 8

17 years ago
Are you sure?  That bug is about query.cgi, not show_bug.cgi.  And when do you
expect this change to appear on Mozilla's version?
doh, you're right.  However, I don't see any mention of show_bug.cgi anywhere in
the comments until the one you just said saying so, but yes, indeed, that form
still has a reset button on it...

based on the comments in bug 98079, we may want to go with leaving it on the
form, but putting some separation between them.  That'll be covered on bug 110012.

Since all previous comments on this bug seemed to indicate query.cgi, I'd just
as soon leave this one closed.  Feel free to add comments requesting that change
to bug 110012 though.
*** Bug 122272 has been marked as a duplicate of this bug. ***
fixing incorrect milestones on fixed bugs.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.16
*** Bug 141724 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.