Unable to select both a fitted t-shirt size and a straight-cut t-shirt size on profile creation.

VERIFIED WONTFIX

Status

Participation Infrastructure
Phonebook
VERIFIED WONTFIX
4 years ago
4 years ago

People

(Reporter: Gareth Walters, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.57 Safari/537.36

Steps to reproduce:

OS: Windows 7 Pro 64 bit
Browser: Chrome

On creating a profile, I selected a fitted t-shirt size and tried to select a straight-cut t-shirt size as well.


Actual results:

I could only select one type of t-shirt and one t-shirt size.


Expected results:

Users may want to select both types of t-shirt. This feature would be useful for users who want to select a women's t-shirt size and a unisex t-shirt size.
I don't understand this bug, can you please clarify? Why would you want to select both types of t-shirt? It seems like this would just confuse whomever is giving out shirts, because they're not going to give you two shirts just because you selected two sizes. How would they know which one to give you?
(Reporter)

Comment 2

4 years ago
Hi Andrei

Sorry for the confusion.

I see what you are saying. However, in my opinion, the problem is that there is an assumption that a fitted t-shirt size is equal to a straight-cut size and vice versa. This is not always the case. A person may prefer a fitted t-shirt in one size and a straight-cut t-shirt in another.

My suggestion for this section of the profile creation form would be to break it down into a couple more parts. A fitted t-shirt size preference, a square-cut t-shirt preference and a preference for fitted or square-cut in the event that both are available.

What do you think?
Gareth, thanks for filing the bug and I think you bring up a valid point.

While more tshirt fields and preferences may be useful, I don't think it's worth the effort right now. The main value of the t-shirt size field at the moment is for finding out the overall tshirt distribution of Mozillians for bulk orders. In the future some functional areas plan to get tshirts to people individually, and if there's a need to have more tshirt options, we can discuss that when we see a need for it.

At the moment, I don't think there is a need and I am marking this bug as wontfix. Let's reopen the bug if we start to see the need for more tshirt options. Thanks again for starting this conversation Gareth :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
QA verified wontfix per :williamr's thought in comment 3 -- thank for filing a well reasoned bug report, please keep them coming.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.