If you click on Contact Member Services, Mozilla crashes.

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: jrose1, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803
BuildID:    2001080312

Whether you goto http://www.aetnaushc.com/member/index.html and click on the
Contact Member Services link or paste the link
(http://www.aetnaushc.com/member/forward_member_services.html) into the browser,
Mozilla crashes and dumps core.

Reproducible: Always
Steps to Reproduce:
1. Goto http://www.aetnaushc.com/member/index.html
2. Click on the Contact Member Services link in the middle of the page
3. Curse aloud

Actual Results:  All Mozilla windows close and a core file is produced.

Expected Results:  Opened the URL.

Here is the source of the HTML page to which the Contact Member Services link leads.

<HTML>
<HEAD>
    <meta http-equiv=refresh content="0;
URL=https://www2.aetnaushc.com/mbrpub/ContactMs_step1.jsp">
<TITLE>
Aetna Navigator Forward Contact Member Services
</TITLE>
</HEAD>
<BODY>
</body>
</html>

Comment 1

17 years ago
On Macintosh, this doesn't crash Mozilla, but it never, ever finishes loading
the page.

There should be a quote character immediately before URL= in the source code. If
you want an fix for this site only, you can email them and tell them to fix the
code - I bet that's what's confusing poor mozilla.

However, in a broader sense, Mozilla should deal with unclosed quotes better.

Comment 2

17 years ago
worksforme, build 2001-08-06-03 on Windows 98 SE.
(Reporter)

Comment 3

17 years ago
Actually it seems to be the fact that it's a secure (https) url. I just tried
going to https://www.safeweb.com and Mozilla did the exact same thing. I know I
didn't have this problem with Mozilla 0.9.1/Netscape 6.1PR1, and I'm almost
positive I didn't have this problem with Mozilla 0.9.2.

Comment 4

17 years ago
WorksForMe Linux 2001082908

Comment 5

17 years ago
I'll have to say two things: on linux, I get the same result as spiraldm:
Both urls (https://www.safeweb.com) load eternally, and if left enough time,
hang the browser. However, I have a hard time grabbing the source using 

b) The URL in question is actually:

https://www.aetna.com/mbrpub/ContactMs_step1.jsp

This has nothing to do with the refresh URL (and note that is IS quoted, as part
of the REFRESH content). Over to SSL.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
No crash for me. I'll have to say two things: on linux, occasionally I will get
the same result as spiraldm: Both urls (https://www.safeweb.com) load eternally,
and if left enough time, hang the browser. This is not what this bug describes,
however.

a) Cannot reproduce crash in bug 2001083108 at all
b) The URL site seems to have connectivity problems, and hangs sometimes when
-dumping with lynx.
c) The URL in question is actually:

https://www.aetna.com/mbrpub/ContactMs_step1.jsp

This has nothing to do with the refresh URL quoting (and note that is IS quoted,
as part of the REFRESH content).

I'm marking WORKSFORME; reporter, try with a newer build and reopen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.