Firefox cant register new protocol handler on Linux

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: axel.braun, Unassigned)

Tracking

25 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 2013102400

Steps to reproduce:

Following the hints given in http://kb.mozillazine.org/Register_protocol I tried to register a protocol for the tryton client (openSUSE 12.3):

In Bowser-bar: about:config

Right-click -> New -> Boolean -> Name: 
network.protocol-handler.external.tryton -> Value -> true

Next:
Right-click -> New -> String -> Name: network.protocol-handler.app.tryton -> 
Value -> /usr/bin/tryton

Ensure network.protocol-handler.expose-all is set to true. 




Actual results:

Firefox doesn't know how to open this address, because the protocol (tryton) isn't associated with any program.




Expected results:

The URL 
tryton://myserver.net:8000/HMH/model/sale.opportunity;views=[376%2C+375]
is launched with the tryton client. Running 
/usr/bin/tryton tryton://myserver.net:8000/HMH/model/sale.opportunity;views=[376%2C+375] works!

Updated

5 years ago
Component: Untriaged → File Handling
With latest Aurora (build ID: 20131119004000) on Ubuntu 13.10 64-bit I've tried the following:

1) in a terminal:

sudo gconftool-2 -s /desktop/gnome/url-handlers/tryton/command '/usr/bin/tryton %s' --type String

sudo gconftool-2 -s /desktop/gnome/url-handlers/tryton/enabled --type Boolean true


2) followed the below steps:

> In Bowser-bar: about:config
> 
> Right-click -> New -> Boolean -> Name: 
> network.protocol-handler.external.tryton -> Value -> true
> 
> Next:
> Right-click -> New -> String -> Name: network.protocol-handler.app.tryton -> 
> Value -> /usr/bin/tryton
> 
> Ensure network.protocol-handler.expose-all is set to true. 


3) loaded in a tab: tryton://myserver.net:8000/HMH/model/sale.opportunity;views=[376%2C+375]

Results: ---> I get this error in the tab from step 3):   " The address wasn't understood

Firefox doesn't know how to open this address, because the protocol (tryton) isn't associated with any program.

    You might need to install other software to open this address. " 



Axel, is this what you're also seeing?
Flags: needinfo?(axel.braun)
(Reporter)

Comment 2

5 years ago
I have already a problem with the first command:

docb@T520:~> su
Passwort: 
T520:/home/docb # gconftool-2 -s /desktop/gnome/url-handlers/tryton/command '/usr/bin/tryton %s' --type String

(gconftool-2:4923): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Fehler beim Zuweisen des Wertes: D-BUS-Hintergrunddienst läuft nicht

T520:/home/docb # ps ax |grep dbus
  686 ?        Ss     0:03 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation
  890 ?        Ss     0:00 /usr/bin/ck-launch-session /usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/gpg-agent --sh --daemon --write-env-file /home/docb/.gnupg/agent.info /usr/bin/ssh-agent /etc/X11/xinit/xinitrc
 1106 ?        S      0:00 /usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/gpg-agent --sh --daemon --write-env-file /home/docb/.gnupg/agent.info /usr/bin/ssh-agent /etc/X11/xinit/xinitrc
 1107 ?        Ss     0:05 /bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
 4926 pts/1    S+     0:00 grep --color=auto dbus
T520:/home/docb # 


...and should the '/usr/bin/tryton %s' command not contain a %u (for a single URL)?
Flags: needinfo?(axel.braun)
Boris, could you please take a look? Thanks!
Sorry, I have no idea how this stuff works on Linux nowadays...
Setting this to NEW, based on comment 1 and comment 2.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

5 years ago
I have checked back with the SUSE-Folks, see https://bugzilla.novell.com/show_bug.cgi?id=852013

On a new installation of SUSE 13.1 I solved it according to https://bugs.tryton.org/issue3479
That works for me at the moment. Just this gconftool-2 seems to be outdated. I have no idea how this works in other distros
Closing this based on comment 6. Please reopen the bug if you can still reproduce the issue. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.