Closed Bug 939172 Opened 7 years ago Closed 7 years ago

Search engine listing icons vary in size

Categories

(Firefox for Android :: General, defect)

27 Branch
ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox26 --- unaffected
firefox27 --- unaffected
firefox28 --- affected
fennec 28+ ---

People

(Reporter: aaronmt, Assigned: Margaret)

References

Details

(Keywords: reproducible)

Attachments

(1 file)

See screenshot attached.

--
Nightly (11/15) | HTC One (Android 4.3)
Good build 11.04.2013;
Bad build 11.05.2013;
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fadc8a168bbc&tochange=770de5942471

Tested on HTC ONE X (Android 4.1.1)
Can we narrow this down with mozilla-inbound builds?
Flags: needinfo?(flaviu.cos)
tracking-fennec: ? → 28+
Bug 933459 is in the regression range and sounds suspicious.
Good inbound build 1383627096;
Bad inbound build 1383629022;
Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c5116411da65&tochange=442b47e9fb80

Tested on HTC ONE X (Android 4.1.1)
Flags: needinfo?(flaviu.cos)
04066e075f59	Sriram Ramasubramanian — Bug 934001: ImageView's setImageBitmap() is worse. [r=mfinkle]
17cc01937229	Sriram Ramasubramanian — Bug 933459: Reduce drawables created for FaviconsView. [r=mfinkle]

?
Flags: needinfo?(sriram)
I think the actual issue here is that the icons don't have a dominant background color anymore. Testing on a Nexus 4, the icons are the same size in beta/aurora/nightly. However, in beta they have a dominant color background, in aurora they suffer from bug 926646, and in nightly they have no background.

Aaron, can you confirm this is what you're seeing? Or is there something else I'm missing?
Assignee: nobody → margaret.leibovic
Flags: needinfo?(aaron.train)
Currently (HTC One):

* Aurora - there is a white background around each; Bing appears smaller than the others. Similarly if I install DuckDuckGo. Yahoo looks like largest.

* Nightly - no background around each; Bing appears smaller than the others. Similarity if DuckDuckGo is installed.

* Beta - dominant coloured backgrounds around each; Bing is smaller than the others, same with DuckDuckGo if installed.
Flags: needinfo?(aaron.train)
(In reply to Aaron Train [:aaronmt] from comment #7)
> Currently (HTC One):
> 
> * Aurora - there is a white background around each; Bing appears smaller
> than the others. Similarly if I install DuckDuckGo. Yahoo looks like largest.

That's bug 926646. I kinda wonder if we should just uplift whatever patch caused us to get rid of the background altogether if we don't have a dominant color, likely one of Sriram's patches.

> * Nightly - no background around each; Bing appears smaller than the others.
> Similarity if DuckDuckGo is installed.
> 
> * Beta - dominant coloured backgrounds around each; Bing is smaller than the
> others, same with DuckDuckGo if installed.

In all these cases, the Bing icon is smaller than all the others because, well, the Bing icon is smaller than all the others. Bug 946802 will fix this, but there's not much we can do about other third-party icons.
This isn't a regression, since the icons never changed size. If there is a regression, it's really bug 926646, which I'm going to morph into being about the fact that we don't get a dominant color for icons that aren't in the cache. Bug 933459 was responsible for making the white background go away, but it did not change the size of the icons themselves.

Bug 946802 fixes the small Bing icon issue, but I don't think there's really anything we can do for smaller icons from other search serivces, so I'm going to resolve this as INVALID.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(sriram)
Keywords: regression
Resolution: --- → INVALID
Duplicate of this bug: 950928
You need to log in before you can comment on or make changes to this bug.