mach bootstrap does not include gcc-g++ on fedora 19

RESOLVED FIXED in mozilla29

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: jhford, Assigned: jhford)

Tracking

unspecified
mozilla29
x86
macOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I ran ./mach bootstrap on a minimal fedora 19 system and gcc-g++ wasn't included in the set of packages installed.  Listing a package that's in a package group as an individual package shouldn't do any harm.
Posted patch fixSplinter Review
This fixes it for me on Fedora 19.  Installing a package that's already there doesn't cause failures, so this is safe even for machines which already have gcc-c++
Attachment #8335593 - Flags: review?(gps)
Comment on attachment 8335593 [details] [diff] [review]
fix

Review of attachment 8335593 [details] [diff] [review]:
-----------------------------------------------------------------

I couldn't find gcc-c++ in the Fedora online package database. But I did find gcc. Is gcc-c++ supported in all versions of Fedora? If not, this should be behind a conditional.

I'd like more info before granting review so we don't inadvertently bust bootstrap for Fedora 20+.

::: python/mozboot/mozboot/fedora.py
@@ +20,3 @@
>              'GNOME Software Development')
>          self.yum_install(
> +            'gcc-c++',

Please alphabetize the list.
jhford: Are you still interested in landing this?
Flags: needinfo?(jhford)
Sorry, didn't see the review comments as I am absolutely flooded by spam from uplifting.

Yes, I think it's still a worthwhile fix.  I double checked that the gcc-c++ package is in the repo metadata for the fedora 20 repository as you called that out specifically.  I also verified that this package is present for all supported release versions as well as Fedora nightlies (aka Rawhide).  I didn't bother to go back to 17 and before, but I've always known this to be the name of the c++ compiler on Fedora, and I started on Fedora 8.

This is a snippet from the metadata of the Fedora 20 repository:

 296973 <package type="rpm">
 296974   <name>gcc-c++</name>
 296975   <arch>x86_64</arch>
 296976   <version epoch="0" ver="4.8.2" rel="1.fc20"/>
 296977   <checksum type="sha256" pkgid="YES">8f8c7bdafa1e1c0fea890fb8cccd2a695875ede7b84fe4d86774b3ff440cb8dd</checksum        >
 296978   <summary>C++ support for GCC</summary>
 296979   <description>This package adds C++ support to the GNU Compiler Collection.
 296980 It includes support for most of the current C++ specification,
 296981 including templates and exception handling.</description>
 296982   <packager>Fedora Project</packager>
 296983   <url>http://gcc.gnu.org</url>
 296984   <time file="1382134733" build="1382009130"/>
 296985   <size package="7501188" installed="17259523" archive="17266072"/>
 296986 <location href="Packages/g/gcc-c++-4.8.2-1.fc20.x86_64.rpm"/>  

And here are the packages for all current versions of Fedora:

http://mirrors.kernel.org/fedora/development/rawhide/x86_64/os/Packages/g/gcc-c++-4.8.2-7.fc21.x86_64.rpm
http://mirrors.kernel.org/fedora/releases/20/Everything/x86_64/os/Packages/g/gcc-c++-4.8.2-1.fc20.x86_64.rpm
http://mirrors.kernel.org/fedora/releases/19/Everything/x86_64/os/Packages/g/gcc-c++-4.8.1-1.fc19.x86_64.rpm
http://mirrors.kernel.org/fedora/releases/18/Everything/x86_64/os/Packages/g/gcc-c++-4.7.2-8.fc18.x86_64.rpm
Flags: needinfo?(jhford)
Comment on attachment 8335593 [details] [diff] [review]
fix

Review of attachment 8335593 [details] [diff] [review]:
-----------------------------------------------------------------

r+ given answers to comments. Please alpabetize the list, however.
Attachment #8335593 - Flags: review?(gps) → review+
Duplicate of this bug: 960362
https://hg.mozilla.org/integration/mozilla-inbound/rev/ea1d1a255701
Assignee: nobody → jhford
Status: NEW → ASSIGNED
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/ea1d1a255701
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.