shouldn't visited links still use 'hover' properties?

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: rpertusio, Assigned: karnaze)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3+)
Gecko/20010805
BuildID:    20010805

Using CSS, shouldn't the properties of the "hover" state of a link still work
after the link has been visited?

An example:
-------------
a:link {
text-decoration: underline;
}

a:visited {
text-decoration: none;

a:hover {
text-decoration: overline;
}
---------------

I may be mis-interpreting the rules of W3C, but shouldn't hovering over a
visited link show an "overline" ??

This may be against the W3C rules, but I haven't found any W3C guidelines that
tell me what Mozilla _should_ be displaying.

I'm very sorry if I missed a W3C rule somewhere, or if this might be more of a
RFE instead.

Reproducible: Always
Steps to Reproduce:
(I'm sorry, I have no example page or testcase at this point)

1. hover over an un-visited link  (link should change from underline to overline
2. click the link, and visit the page/link
3. return to the original page, and hover over the visited link.  (there is no
underline/overline, and doesn't change to overline when hovered)

Actual Results:  Using the snippet of CSS code above, hovering over visited link
does not show an overline, but keeps the 'text-decoration' to "none"  (no
underline or overline)

Expected Results:  visited link should have an overline when hovered, just like
an "un-visited" link does.

Comment 1

18 years ago
To be completely unambiguous about it, a rule like a:visited:hover will define
exactly what should happen to an element that is both visited and being hovered.
(Otherwise, i guess it goes by the order you put the style rules in)

However, in the current build of mozilla (Mac OS 9/2001080214), a
"a:visited:hover" rule seems not to have any effect (ie, behaves as though the
rule wasn't there). To be sure I wasn't losing my sanity, I tried
a:hover:visited too. Nothing. Searched the database for a duplicate. Nothing.

Comment 2

18 years ago
a:visited has no closing bracket. If you fix that, it works fine. :o)

can't reproduce on Win2K 2001080508 build.
if you can still reproduce it, please reopen.
marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

18 years ago
Hrmm.. How dumb of me : I've spent a couple of hours trying to figure out what
could have been wrong. Doh! A simple bracket slips my eye.  ** reaches for
glasses **   

However, I might suggest "emlyyn@yahoo.com" open a new bug report for that
specific problem.  (I'll trust that the CSS specifications you gave are valid
CSS. I personally wasn't aware of those CSS specification you specified.)

emlynn, post to a new bug if you're sure it is valid CSS, because this bug wont
be looked at (much) now that it is closed/resolved/invalid/etc..

Sorry for the troubles!
Vrfy Invalid

Ryan: a good resource before submitting CSS bugs is the W3C CSS Validator at
http://jigsaw.w3.org/css-validator/

Thanks for helping test mozilla :)
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
No,that's not a bug. I was playing around with the bracketless code, not writing
it myself. Stupid of me.  No bugs here, people, move along, moving along.
You need to log in before you can comment on or make changes to this bug.