Startup crash: java.lang.UnsatisfiedLinkError: Couldn't load mozglue from loader dalvik.system.PathClassLoader[dexPath=/data/app/org.mozilla.firefox-2.apk,libraryPath=/data/app-lib/org.mozilla.firefox-2]: findLibrary returned null

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

({crash})

25 Branch
All
Android
crash
Points:
---

Firefox Tracking Flags

(firefox25 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Firefox 25.0.1 installed via Google Play (AFAIK) on Sony Xperia L, Android 4.2, is crashing on startup. Occurs after reboot.

See also Bug 848715, Bug 848715?

W/dalvikvm(17706): threadid=1: thread exiting with uncaught exception (group=0x410c9ae0)
E/AndroidRuntime(17706): FATAL EXCEPTION: main
E/AndroidRuntime(17706): java.lang.UnsatisfiedLinkError: Couldn't load mozglue from loader dalvik.system.PathClassLoader[dexPath=/data/app/org.mozilla.firefox-2.apk,libraryPath=/data/app-lib/org.mozilla.firefox-2]: findLibrary returned null
E/AndroidRuntime(17706): 	at java.lang.Runtime.loadLibrary(Runtime.java:365)
E/AndroidRuntime(17706): 	at java.lang.System.loadLibrary(System.java:535)
E/AndroidRuntime(17706): 	at org.mozilla.gecko.mozglue.GeckoLoader.loadMozGlue(GeckoLoader.java:246)
E/AndroidRuntime(17706): 	at org.mozilla.gecko.GeckoApplication.onCreate(GeckoApplication.java:101)
E/AndroidRuntime(17706): 	at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1001)
E/AndroidRuntime(17706): 	at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4447)
E/AndroidRuntime(17706): 	at android.app.ActivityThread.access$1300(ActivityThread.java:145)
E/AndroidRuntime(17706): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1298)
E/AndroidRuntime(17706): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime(17706): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime(17706): 	at android.app.ActivityThread.main(ActivityThread.java:5099)
E/AndroidRuntime(17706): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(17706): 	at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime(17706): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:803)
E/AndroidRuntime(17706): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:570)
E/AndroidRuntime(17706): 	at dalvik.system.NativeStart.main(Native Method)
(Reporter)

Comment 1

5 years ago
This is the same symptom as if an ARMv7 binary is used on ARMv6, IIRC, but this is an ARMv7 device (Snapdragon MSM8230).

Comment 2

5 years ago
Created attachment 833302 [details]
Screenshot

Yes, installed and updated from Google Play. Previous version 25.0 was not crashing. Not sure if it helps, but here is a screenshot of the crash. The blank area in the background appears briefly then disappears, then only the popup is kept displayed.

Comment 3

5 years ago
Not reproducible in Firefox Beta 26.0 from Play Store. I also have fixed the problem by reinstalling stable release (25.0.1). I have then restored the app data from a backup performed right before reinstalling, using a Sony utility. All of my settings look just ok like they were before, and the crash is gone. So I think data corruption is not the case, also something in the reinstall process did the trick. Thus the problem is fixed for me and it's up to you guys whether to close this bug or not. Thanks!

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.