No specifiable login to news server

VERIFIED INVALID

Status

VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: charleshixsn, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010806
BuildID:    2001080608

I need to log into my newsgroup server, but there seems to be no way to specify
this.  When I try to collect the list of newsgroups, instead of asking for my
logon id, it tells me that only members can log on.  PAN couldn't handle this
either, so it's likely a firewall problem.  But there is no diagnostic except: 
it failed.


Reproducible: Always
Steps to Reproduce:
1.select newsgroup
2.Attempt to download a list of new groups
3.
Earthlink is very strict; you have to physically be on the network when you
attempt to use newsgroups (same with SMTP also, it will check your IP
address/hostname).  Can you please tell us the exact error message you get?  

In response to:

"instead of asking for my
logon id, it tells me that only members can log on", that seems logical, since
you mentioned you are behind a firewall, and therefore, it's not recognizing
your IP block as valid.  Earthlink has very agressive anti-spam measures.  

Component: Account Manager → Networking - News
re-assigning over back to networking-news, resetting defaults.
Assignee: racham → sspitzer
QA Contact: nbaca → stephend
(Reporter)

Comment 3

17 years ago
The error message received was:
A News (NNTP) error occurred: Permission Denied - Earthlink News service is
restricted to
EarthLink Member Networks --newssupport@EarthLink.Net (Typhoon v1.2.4)

I don't doubt that this is a firewall problem (it seems to be), but it's not
obvious to me how to tell whether or not this is something that I can do
something about.  (I had been able to connect until a recent change was made,
and I don't know what the change was.  [The happenstance that this corresponded
to my reinstalling Linux further confused things.  Naturally that's when it
would happen.])
Mozilla here is just returning the server's failure message, Seth, isn't this 
all we can do at this level, since Earthlink is blocking him because of not 
finding the IP block?
from the comments, I don't see the bug.
all we can do is put up the alert the server gives us.
what do 4.x or other news readers do?
I used to dialup using Earthlink.  All did the same thing (Outlook Express, NS
4.7x, etc.)  They always threw up the server-specified (originating from
Earthlink) message...
thanks for seeing what the other newsreaders did.

invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Just FYI, here's Outlook Express 6's error message:

502 Permission Denied - EarthLink News service is restricted to EarthLink Member
Networks --newssupport@EarthLink.Net (Typhoon v1.2.4)

Configuration:
   Account: news.earthlink.net
   Server: news.earthlink.net
   User name: stephendonner
   Protocol: NNTP
   Port: 119
   Secure(SSL): 0
   Error Number: 502
   Code: 800ccca0

So, we're exactly the same as Outlook Express (meaning we truly return the
server error only, which is AFAIKT the right thing to do).

Verified INVALID, sorry Earthlink is so strict.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.