MathML mtable columnalign not heeded

RESOLVED DUPLICATE of bug 491384

Status

()

Core
MathML
RESOLVED DUPLICATE of bug 491384
4 years ago
4 years ago

People

(Reporter: manday, Unassigned)

Tracking

25 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

32.47 KB, text/html
Details
(Reporter)

Description

4 years ago
Created attachment 8333507 [details]
sheet.html

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.32 (KHTML, like Gecko) Chromium/25.0.1349.2 Chrome/25.0.1349.2 Safari/537.32

Steps to reproduce:

Convert HTML with embedded TeX-like equations to valid HTML5 with MathML (see attached) with itex2MML (http://golem.ph.utexas.edu/~distler/blog/itex2MML.html)

firefox-bin version 25.0 on Gentoo Linux


Actual results:

itex2MML is given \begin{arrray}{rcl} environments which are turned into <mtable columnalign="right center left"> nodes, however, the contents are all centered when rendered in Firefox. But they do align as desired when viewed in "Print Preview"!

See any multiline equation (with aligned "="s) in the attached document.
(Reporter)

Updated

4 years ago
See Also: → bug 491384
Thanks for the bug report. That's probably bug 491384 which should be fixed with the patch of bug 731667.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491384
You need to log in before you can comment on or make changes to this bug.