Closed Bug 939587 Opened 9 years ago Closed 9 years ago

Touching js/src/moz.build doesn't regenerate the build backend

Categories

(Firefox Build System :: General, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla28

People

(Reporter: ehsan.akhgari, Assigned: gps)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1. touch js/src/moz.build
2. ./mach build

The "reticulating" message is never printed and the new backend files are not generated.
This is most definitely a regression. Bug 930896 perhaps? Whatever the cause, this can be a source of needed clobbers, so it's a P1.
Keywords: regression
Priority: -- → P1
This should do it. Basically copied some rules from /Makefile.in.
Attachment #8334086 - Flags: review?(mh+mozilla)
Assignee: nobody → gps
Status: NEW → ASSIGNED
Attachment #8334086 - Flags: review?(mh+mozilla) → review+
Bug 936689 and bug 940404 are presumably dupes of this.
Duplicate of this bug: 936689
Duplicate of this bug: 940404
https://hg.mozilla.org/mozilla-central/rev/133f7eae3078
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Blocks: clobber
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.