Closed Bug 939626 Opened 6 years ago Closed 6 years ago

Intermittent testPrivateBrowsing | Exception caught - junit.framework.AssertionFailedError: EditText is not found!

Categories

(Firefox for Android :: Testing, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 915449

People

(Reporter: philor, Assigned: gbrown)

References

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=30667063&tree=Mozilla-Inbound
Android 4.0 Panda mozilla-inbound opt test robocop-4 on 2013-11-17 15:23:09 PST for push 78fd5daacc01
slave: panda-0336

15:37:39     INFO -  14 INFO TEST-PASS | testPrivateBrowsing | The correct number of tabs are opened - 2 should equal 2
15:37:39     INFO -  Exception caught during test!
15:37:39     INFO -  junit.framework.AssertionFailedError: EditText is not found!
15:37:39     INFO -  	at junit.framework.Assert.fail(Assert.java:47)
15:37:39     INFO -  	at junit.framework.Assert.assertTrue(Assert.java:20)
15:37:39     INFO -  	at com.jayway.android.robotium.solo.Waiter.waitForAndGetView(Waiter.java:501)
15:37:39     INFO -  	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:49)
15:37:39     INFO -  	at com.jayway.android.robotium.solo.Solo.getEditText(Solo.java:1829)
15:37:39     INFO -  	at org.mozilla.gecko.tests.BaseTest$1.isSatisfied(BaseTest.java:199)
15:37:39     INFO -  	at com.jayway.android.robotium.solo.Waiter.waitForCondition(Waiter.java:361)
15:37:39     INFO -  	at com.jayway.android.robotium.solo.Solo.waitForCondition(Solo.java:420)
15:37:39     INFO -  	at org.mozilla.gecko.tests.BaseTest.waitForCondition(BaseTest.java:311)
15:37:39     INFO -  	at org.mozilla.gecko.tests.BaseTest.focusUrlBar(BaseTest.java:196)
15:37:39     INFO -  	at org.mozilla.gecko.tests.BaseTest.enterUrl(BaseTest.java:215)
15:37:39     INFO -  	at org.mozilla.gecko.tests.BaseTest.inputAndLoadUrl(BaseTest.java:246)
15:37:39     INFO -  	at org.mozilla.gecko.tests.PixelTest.loadAndGetPainted(PixelTest.java:10)
15:37:39     INFO -  	at org.mozilla.gecko.tests.PixelTest.loadAndPaint(PixelTest.java:23)
15:37:39     INFO -  	at org.mozilla.gecko.tests.PixelTest.addTab(PixelTest.java:60)
15:37:39     INFO -  	at org.mozilla.gecko.tests.testPrivateBrowsing.addTab(testPrivateBrowsing.java:16)
15:37:39     INFO -  	at org.mozilla.gecko.tests.testPrivateBrowsing.testPrivateBrowsing(testPrivateBrowsing.java:52)
15:37:39     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
15:37:39     INFO -  	at java.lang.reflect.Method.invoke(Method.java:511)
15:37:39     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:214)
15:37:39     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:199)
15:37:39     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:192)
15:37:39     INFO -  	at org.mozilla.gecko.tests.BaseTest.runTest(BaseTest.java:154)
15:37:39     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:127)
15:37:39     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:106)
15:37:39     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:124)
15:37:39     INFO -  	at junit.framework.TestResult.run(TestResult.java:109)
15:37:39     INFO -  	at junit.framework.TestCase.run(TestCase.java:118)
15:37:39     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
15:37:39     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
15:37:39     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:545)
15:37:39     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1551)
15:37:39     INFO -  15 INFO TEST-UNEXPECTED-FAIL | testPrivateBrowsing | Exception caught - junit.framework.AssertionFailedError: EditText is not found!
15:37:39     INFO -  16 INFO TEST-END | testPrivateBrowsing | finished in 58539ms
See Also: → 915449
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915449
You need to log in before you can comment on or make changes to this bug.