Crash when dismiss print content dialog before print

VERIFIED DUPLICATE of bug 58011

Status

SeaMonkey
MailNews: Message Display
--
critical
VERIFIED DUPLICATE of bug 58011
17 years ago
13 years ago

People

(Reporter: Karen Huang, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, pp})

Trunk
x86
Linux
crash, pp

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Used 08-06-08-trunk build

Crash when dismiss print content dialog before print

1) Login to a Mail account.
2) Select a mail msg to print
3) A small dialog will prompt for display the content of the print msg
4) Dismiss this dialog by selecting the "x" from the upper right corner before
define for print.
Actual Results: Crash.

Expected result: Should dismiss this small print content dialog successfully
without the crash.
(Reporter)

Comment 1

17 years ago
Created attachment 44845 [details]
Attach the screen shot of dialog that I dismiss causing crash
(Reporter)

Comment 2

17 years ago
Adding crash & pp for the keywords since problem cannot be reproduced on
Windows.
Severity: normal → critical
Keywords: crash, pp
(Reporter)

Comment 3

17 years ago
Please see the above URL for the talk back report.
Stack Trace

nsDocShell::GetCurrentDocumentOwner() 
nsDocShell::InternalLoad() 
nsDocShell::LoadURI() 
nsDocShell::LoadURI() 
nsMsgPrintEngine::FireThatLoadOperation() 
nsMsgPrintEngine::StartNextPrintOperation() 
nsMsgPrintEngine::OnEndPrinting() 
PrintData::OnEndPrinting() 
DocumentViewerImpl::Destroy() 
nsDocShell::Destroy() 
nsWebShell::Destroy() 
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame() 
nsFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsBoxFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
nsBoxFrame::Destroy() 
nsFrameList::DestroyFrames() 
nsContainerFrame::Destroy() 
ViewportFrame::Destroy() 
FrameManager::Destroy() 
PresShell::Destroy() 
DocumentViewerImpl::Destroy() 
nsDocShell::Destroy() 
nsWebShell::Destroy() 
nsXULWindow::Destroy() 
nsWebShellWindow::Destroy() 
nsWebShellWindow::Close() 
nsWebShellWindow::HandleEvent() 
nsWidget::DispatchEvent() 
handle_delete_event() 
libgtk-1.2.so.0 + 0x8d719 (0x40279719) 
libgtk-1.2.so.0 + 0xbafdd (0x402a6fdd) 
libgtk-1.2.so.0 + 0xba422 (0x402a6422) 
libgtk-1.2.so.0 + 0xb8575 (0x402a4575) 
libgtk-1.2.so.0 + 0xed77c (0x402d977c) 
libgtk-1.2.so.0 + 0x8c700 (0x40278700) 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x1700b (0x4032300b) 
libglib-1.2.so.0 + 0xfbe6 (0x40350be6) 
libglib-1.2.so.0 + 0x101a1 (0x403511a1) 
libglib-1.2.so.0 + 0x10254 (0x40351254) 
nsAppShell::DispatchNativeEvent() 
nsXULWindow::ShowModal() 
nsWebShellWindow::ShowModal() 
nsContentTreeOwner::ShowAsModal() 
nsWindowWatcher::OpenWindowJS() 
nsWindowWatcher::OpenWindow() 
nsDeviceContextSpecGTK::Init() 
nsDeviceContextSpecFactoryGTK::CreateDeviceContextSpec() 
DocumentViewerImpl::Print() 
nsMsgPrintEngine::OnStateChange() 
nsDocLoaderImpl::FireOnStateChange() 
nsDocLoaderImpl::doStopDocumentLoad() 
nsDocLoaderImpl::DocLoaderIsEmpty() 
nsDocLoaderImpl::OnStopRequest() 
nsLoadGroup::RemoveRequest() 
PresShell::RemoveDummyLayoutRequest() 
PresShell::DoneRemovingReflowCommands() 
PresShell::ProcessReflowCommands() 
HandlePLEvent() 
PL_HandleEvent() 
PL_ProcessPendingEvents() 
nsEventQueueImpl::ProcessPendingEvents() 
event_processor_callback() 
our_gdk_io_invoke() 
libglib-1.2.so.0 + 0xe52a (0x4034f52a) 
libglib-1.2.so.0 + 0xfbe6 (0x40350be6) 
libglib-1.2.so.0 + 0x101a1 (0x403511a1) 
libglib-1.2.so.0 + 0x10341 (0x40351341) 
libgtk-1.2.so.0 + 0x8c209 (0x40278209) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x181eb (0x404481eb) 

Comment 4

17 years ago
This dialog is not from the printing code, must be a mailnews window.
Component: Printing → Mail Window Front End

Comment 5

17 years ago
Assigning to mailnews.. this is not a printing issue.
Assignee: dcone → sspitzer
dup of a bug cavin owns, that we've got a patch started for.

Comment 7

17 years ago
This one you mean?

*** This bug has been marked as a duplicate of 58011 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.