All users were logged out of Bugzilla on October 13th, 2018

Firefox fails to build on PPC64: jsatom.cpp:507:24: error: no match for ‘operator<’

RESOLVED DUPLICATE of bug 939504

Status

()

--
blocker
RESOLVED DUPLICATE of bug 939504
5 years ago
5 years ago

People

(Reporter: gustavold, Unassigned)

Tracking

Trunk
PowerPC
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Firefox (m-c) fails to build on PPC64 with the following error message:

 1:51.80 /home/buildbot/buildbot/slave/runtests/build/js/src/jsatom.cpp: In function ‘bool js::XDRAtom(js::XDRState<mode>*, js::MutableHandleAtom)’:
 1:51.80 /home/buildbot/buildbot/slave/runtests/build/js/src/jsatom.cpp:507:24: error: no match for ‘operator<’ (operand types are ‘JSAtom*(js::ExclusiveContext*, const jschar*, size_t, js::InternBehavior) {aka JSAtom*(js::ExclusiveContext*, const char16_t*, long unsigned int, js::InternBehavior)}’ and ‘js::AllowGC’)


The full build log can be found here: http://mozillaproject.osuosl.org:8010/builders/runtests/builds/526/steps/shell/logs/stdio
(Reporter)

Comment 1

5 years ago
This seems to have been introduced by bug #928050
Blocks: 928050
(Reporter)

Comment 2

5 years ago
Created attachment 8333862 [details] [diff] [review]
Fix build failure on PPC64

I applied this patch and tried to build Firefox on PPC64. It fails then on a different place, which seems to be a different issue introduced by changeset 2bbd3a23d40f:


 9:16.88 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp: In static member function ‘static void* js::gc::ArenaLists::refillFreeList(js::ThreadSafeContext*, js::gc::AllocKind)’:
 9:16.88 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp:1570:49: error: ‘JSRuntime’ has no member named ‘workerThreadState’
 9:16.88              AutoLockWorkerThreadState lock(*rt->workerThreadState);
 9:16.88                                                  ^
 9:16.88 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp:1572:21: error: ‘JSRuntime’ has no member named ‘workerThreadState’
 9:16.88                  rt->workerThreadState->wait(WorkerThreadState::PRODUCER);
 9:16.88                      ^
 9:16.88 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp:1572:45: error: incomplete type ‘js::WorkerThreadState’ used in nested name specifier
 9:16.88                  rt->workerThreadState->wait(WorkerThreadState::PRODUCER);
 9:16.88                                              ^
 9:16.92 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp: In constructor ‘js::gc::AutoTraceSession::AutoTraceSession(JSRuntime*, js::HeapState)’:
 9:16.92 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp:4153:45: error: ‘JSRuntime’ has no member named ‘workerThreadState’
 9:16.92          AutoLockWorkerThreadState lock(*rt->workerThreadState);
 9:16.92                                              ^
 9:16.93 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp: In destructor ‘js::gc::AutoTraceSession::~AutoTraceSession()’:
 9:16.93 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp:4169:50: error: ‘JSRuntime’ has no member named ‘workerThreadState’
 9:16.93          AutoLockWorkerThreadState lock(*runtime->workerThreadState);
 9:16.93                                                   ^
 9:16.94 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp:4173:18: error: ‘JSRuntime’ has no member named ‘workerThreadState’
 9:16.94          runtime->workerThreadState->notifyAll(WorkerThreadState::PRODUCER);
 9:16.94                   ^
 9:16.94 /home/gustavold/upstream/mozilla-central/js/src/jsgc.cpp:4173:47: error: incomplete type ‘js::WorkerThreadState’ used in nested name specifier
 9:16.94          runtime->workerThreadState->notifyAll(WorkerThreadState::PRODUCER);
 9:16.94
Attachment #8333862 - Flags: review?(bhackett1024)
Comment on attachment 8333862 [details] [diff] [review]
Fix build failure on PPC64

Review of attachment 8333862 [details] [diff] [review]:
-----------------------------------------------------------------

I think this is a dupe of bug 939504.
Attachment #8333862 - Flags: review?(bhackett1024) → review+
(Reporter)

Comment 4

5 years ago
Yeah, definitely a dupe, though I'm not sure Sparc64 has also hit the issue described in comment #2. Should I file a separate bug for that?
Can this bug be closed?
I think both issues have been fixed on m-c. I am able to build and run m-c on PPC64
(Reporter)

Comment 6

5 years ago
Yes, I'm closing as duplicate as indicated on comment #3.
Thanks folks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939504
You need to log in before you can comment on or make changes to this bug.