[Keyboard] [jp-kanji] "大小" key should be "小 ゛ ゜"

RESOLVED FIXED

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Masashi Honma, Assigned: Masashi Honma)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Currently jp-kanji keyboard has "大小" key.

Indeed it is used to type mini size version of "やゆよ".
But it can be used to input "濁点" and "半濁点".

So I think the button label should be "小 ゛ ゜".

I modified the gaia/apps/keyboard/js/layouts/jp-kanji.js.
But I could not test it. Because the file is overwritten by

$ GAIA_KEYBOARD_LAYOUTS=en,jp-kanji make reset-gaia

command. If somebody teach me a testing way, I could test the patch and send Pull Request.

Comment 1

4 years ago
Hi Masashi,

After Bug 884752 is landed, you need to modify the layout from "gaia/keyboard/layouts/jp-kanji.js".
Files under "gaia/apps/keyboard/js/layouts/" are generated automatically by "GAIA_KEYBOARD_LAYOUTS" config.
(Assignee)

Comment 2

4 years ago
Created attachment 8334501 [details]
Pull Request
(Assignee)

Updated

4 years ago
Attachment #8334501 - Attachment mime type: text/plain → text/html
Attachment #8334501 - Flags: review?(lchang)
(Assignee)

Comment 3

4 years ago
Thanks Luke !

I made a Pull Request.
Let's ask the original author, Xulei, for his opinion first and then maybe we could ask for UX input on this issue.

Hi Yuan,

Could you please share some insights on the UX of jp keyboard?
Do we have a reference implementation (on Android or something), or it was implemented from scratch by you and Wenbin?

Thanks.
Flags: needinfo?(xyuan)
The UX of the jp keyboard is almost the same as Android OpenWnn IME, which is the reference IME.

OpenWnn is an embeded IME for the standard google android IME. The source code is: https://android.googlesource.com/platform/packages/inputmethods/OpenWnn/

To build and install it as a standalone apk instead of building the whole android source code, you can try a modified version of mine: https://github.com/yxl/Android-OpenWnn

Or you can download the OpenWnn+, which is an enhanced version from google play https://play.google.com/store/apps/details?id=com.owplus.ime.openwnnplus&hl=en_US
Flags: needinfo?(xyuan)
(In reply to Masashi Honma from comment #0)
> Currently jp-kanji keyboard has "大小" key.
> 
> Indeed it is used to type mini size version of "やゆよ".
> But it can be used to input "濁点" and "半濁点".
> 
> So I think the button label should be "小 ゛ ゜".
The "大小" key is used to switch between "大" version of "やゆよ" and the "小" version of "やゆよ" as well as that of "濁点" and "半濁点".
So "小 ゛ ゜" is not enough to show the key function, we also need something like "大 ..." to switch from "小" mode to "大" mode.
(Assignee)

Comment 7

4 years ago
(In reply to Yuan Xulei [:yxl] from comment #6)
> The "大小" key is used to switch between "大" version of "やゆよ" and the "小"
> version of "やゆよ" as well as that of "濁点" and "半濁点".
> So "小 ゛ ゜" is not enough to show the key function, we also need something
> like "大 ..." to switch from "小" mode to "大" mode.

I think "大" is redundant.
Because it is default on Japanese character.

Indeed Simeji IME keyboard doesn't have "大".
https://play.google.com/store/apps/details?id=com.adamrocker.android.input.simeji&hl=ja

I attached a scrren shot of the Simeji IME keyboard.
(Assignee)

Comment 8

4 years ago
Created attachment 8335120 [details]
Simeji IME keyboard
So, I guess we can see 2 ways to handle this issue in various reference design,

1. 大<=>小 ゛ ゜
  in OpenWnn plus on Android, https://lh4.ggpht.com/-jajFBOKQ1455wDTklha_5IACuIEpLCcWHKuqcSD4SpsLiNwweBUnaUPAsHwtcup8g=h900

2. 小 ゛ ゜
   on iPhone iOS5, http://imgur.com/rN7QO5L
   or Simeji IME, as Comment 7 pointed out.

I would like to call for help from our UX team about this.

--
Carrie,

Could you help guide us on this issue?
I guess if you're fine with either of these approach, we'll just take number 2, as our contributor, Masashi, proposed.
Flags: needinfo?(cawang)
Comment on attachment 8334501 [details]
Pull Request

Hi Masashi,

It seems that we need further discussion about its UX design but the patch looks good to me! I think, however, it's better to be also reviewed by the keyboard owner.

Hi Rudy,

Although you've already joined, could you please help review this? Thanks!
Attachment #8334501 - Flags: review?(rlu)
Attachment #8334501 - Flags: review?(lchang)
Attachment #8334501 - Flags: feedback+
(In reply to Rudy Lu [:rudyl] from comment #9)
> So, I guess we can see 2 ways to handle this issue in various reference
> design,
> 
> 1. 大<=>小 ゛ ゜
>   in OpenWnn plus on Android,
> https://lh4.ggpht.com/-
> jajFBOKQ1455wDTklha_5IACuIEpLCcWHKuqcSD4SpsLiNwweBUnaUPAsHwtcup8g=h900
> 
> 2. 小 ゛ ゜
>    on iPhone iOS5, http://imgur.com/rN7QO5L
>    or Simeji IME, as Comment 7 pointed out.
> 
> I would like to call for help from our UX team about this.
> 
> --
> Carrie,
> 
> Could you help guide us on this issue?
> I guess if you're fine with either of these approach, we'll just take number
> 2, as our contributor, Masashi, proposed.

I'd go with Masashi's suggestion here since we are not the native speaker. Following the 3rd party kb design used for local people would be a safe solution. Thanks!
Flags: needinfo?(cawang)
Comment on attachment 8334501 [details]
Pull Request

Accept Masashi's patch according to UX comment.
r=me.

Thanks.
Attachment #8334501 - Flags: review?(rlu) → review+
Merged to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/49ce817c2c391335d001205edf185bfb8e605352
Assignee: nobody → masashi.honma
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.