Closed Bug 940009 Opened 7 years ago Closed 5 years ago

Australis Customize does not set text color for Restore Defaults button. Difficult to see on dark themes.

Categories

(Firefox :: Theme, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bugs, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P5])

Just that.  Using MATE under Linux, Dark Theme.  Text on Restore Defaults is barely visible w/ text colour I have. Have to squint to make it out.
Would be invisible if my text colour was white.
Whiteboard: [Australis:M?][Australis:P5]
Whiteboard: [Australis:M?][Australis:P5] → [Australis:P5]
This looks like WFM - https://dxr.mozilla.org/mozilla-central/rev/eb25b90a05c194bfd4f498ff3ffee7440f85f1cd/browser/themes/shared/customizableui/customizeMode.inc.css#121,126-127 - so resolving as such.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
User Story: (updated)
Does seem to be fine, at least in the dark theme I'm using these days.
BTW, the curve on tabs looks pretty awful w/ dark themes since it stays light coloured while the middle of that tab is dark coloured.

(ugh. sorry. keep accidentally putting reply comments in the user story textbox.)
User Story: (updated)
(oh. also, tab title text has that same unreadable white on white issue for the unfocused tabs.  I get the feeling no one tests browser CSS w/ inverted background/foreground colours ☺ )
(In reply to nemo from comment #3)
> (oh. also, tab title text has that same unreadable white on white issue for
> the unfocused tabs.  I get the feeling no one tests browser CSS w/ inverted
> background/foreground colours ☺ )

We do, but there's probably fewer people doing that on Linux. Could also be a gtk3 problem, or related to the "dark theme" setting that it has, or specific to a particular theme. Plus, theming on linux, IME, is an inconsistent horrible mess anyway. So many reports go "I'm using the default theme on Ubuntu" and then aren't reproducible with the default theme on Ubuntu, because the reporter "forgot" that they changed it. Either way, the net result is: Please file a separate bug with explicit details about how to reproduce, ideally on a more common wm/desktop env than MATE.
You need to log in before you can comment on or make changes to this bug.