Closed Bug 940107 Opened 9 years ago Closed 9 years ago

Home icon not shown when moved to Bookmarks toolbar, only text

Categories

(Firefox :: Toolbars and Customization, defect)

28 Branch
All
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: walts48, Assigned: jaws)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [Australis:P4])

Attachments

(1 file)

Enter customization.
Move Home icon to the bookmarks toolbar.
Icon appears with no text, quit, restart and the icon is gone, only text appears.
Whiteboard: [Australis:P4]
(In reply to WaltS from comment #1)
> Enter customization.
> Move Home icon to the bookmarks toolbar.
> Icon appears with no text, quit, restart and the icon is gone, only text
> appears.

Can you reproduce this on a clean profile? I suspect this has something to do with stored icon sizes, which was fixed on either today's or yesterday's nightly build. Can you retest? :-)
Flags: needinfo?(schw01)
I can reproduce it using today's build with a clean profile.

Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0
buildID	20131124104839
Built from http://hg.mozilla.org/mozilla-central/rev/74ab61b8d0f0
Flags: needinfo?(schw01)
Confirmed in 28.0a1 (2013-11-27), Ubuntu 12.04 x86.
Works fine on Windows and Mac.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86_64 → All
Attached patch PatchSplinter Review
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8350474 - Flags: review?(mconley)
Comment on attachment 8350474 [details] [diff] [review]
Patch

Review of attachment 8350474 [details] [diff] [review]:
-----------------------------------------------------------------

I was initially concerned that those customizationchange dispatches were unnecessary, since onWidgetAdded / Moved / Removed fire those events. It turns out, however, that the addToMenu, etc. functions can be called when *not* in customize mode, meaning CustomizeMode's CUI listeners aren't set, meaning onWidgetAdded / Moved / Removed are never called.

Those functions *can* be called when we're in customize mode, so we might want to check that we're not in customize mode before firing them again.

::: browser/base/content/browser.js
@@ +1252,4 @@
>  
>      TabsInTitlebar.uninit();
>  
> +

Let's drop this extra newline.
Attachment #8350474 - Flags: review?(mconley) → review+
https://hg.mozilla.org/mozilla-central/rev/88af4d70b4db
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Icon still not showing up using Nightly on openSUSE 13.1 with either KDE or Gnome desktops

Tried Safe Mode, temporary profile, and reset Nightly.

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0
changeset - 162097:8f0d4afd151e
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to WaltS from comment #8)
> Icon still not showing up using Nightly on openSUSE 13.1 with either KDE or
> Gnome desktops
> 
> Tried Safe Mode, temporary profile, and reset Nightly.
> 
> User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101
> Firefox/29.0
> changeset - 162097:8f0d4afd151e

Please file a new bug for this and mark it as blocking this one.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
(In reply to WaltS from comment #0)
> Enter customization.
> Move Home icon to the bookmarks toolbar.
> Icon appears with no text, quit, restart and the icon is gone, only text
> appears.
Now only the text appears also before the restart, there is no icon at all.
29.0a1 (2014-01-07), Ubuntu 12.04 x86.
On Windows I see both the icon and the text, so I would say it's not really fixed ?
Depends on: 957151
(In reply to Paul Silaghi, QA [:pauly] from comment #10)
> (In reply to WaltS from comment #0)
> > Enter customization.
> > Move Home icon to the bookmarks toolbar.
> > Icon appears with no text, quit, restart and the icon is gone, only text
> > appears.
> Now only the text appears also before the restart, there is no icon at all.
> 29.0a1 (2014-01-07), Ubuntu 12.04 x86.
> On Windows I see both the icon and the text, so I would say it's not really
> fixed ?

This patch fixed a legitimate issue. Now we still need to fix the styling on Linux. I filed bug 957151.
Verified fixed on 29.0a1 (2014-01-07), Ubuntu 12.04 x86 based on comment 11.
You need to log in before you can comment on or make changes to this bug.