Marketplace stage CDN returning 404 for many assets

VERIFIED FIXED

Status

Cloud Services
Operations: Marketplace
--
major
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Victor Carciu, Assigned: jason)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

Steps to reproduce:
1.Go to MP Stage homepage 
2.Select a category then open some apps from the category

Expected results:
All icons are visible in the app list and images are visible in app detail pages

Please see screencasts for this bug:
Missing icons: http://screencast.com/t/Eh454CNR0O
Missing images : http://screencast.com/t/HTlsIaRZ

NOTES:
Not reproducible on -dev

Comment 1

4 years ago
Images are also missing from the Dev Hub - App Edit Listing page http://screencast.com/t/FIJO2RHt

Updated

4 years ago
Assignee: nobody → server-ops-amo
Component: Consumer Pages → Server Operations: AMO Operations
Product: Marketplace → mozilla.org
QA Contact: oremj
Target Milestone: 2013-11-19 → ---
Version: Avenir → other

Comment 2

4 years ago
Looks like the CDN is returning a 404 for all of the assets. Jeremy/Jason: can you have a look and see what might be happening?
Summary: Images and icons are missing from Stage → Marketplace stage CDN returning 404 for many assets
(Assignee)

Updated

4 years ago
Assignee: server-ops-amo → jthomas
(Assignee)

Comment 3

4 years ago
The symlinks in default/webroot and mkt/webroot were removed when I was fixing dreadnot stage instance yesterday. Puppet failed to add these symlinks back and nginx was not able to find the path to assets. I fixed puppet configuration and this should now be fixed. Let me know if you continue to have issues.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

4 years ago
Verified as fixed : http://screencast.com/t/9QOtBrhpyZ
Status: RESOLVED → VERIFIED
Component: Server Operations: AMO Operations → Operations: Marketplace
Product: mozilla.org → Mozilla Services
You need to log in before you can comment on or make changes to this bug.