Closed Bug 940292 Opened 6 years ago Closed 6 years ago

Australis: Chevron of Bookmarks Toolbar is broken

Categories

(Firefox :: Toolbars and Customization, defect)

28 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: alice0775, Assigned: Gijs)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [Australis:P1])

Attachments

(2 files)

Attached image screenshot
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/f2adb62d07eb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131118094134

Steps To Reproduce:
1. Make sure Bookmarks Toolbar is overflowed
2. Enter customize mode
3. Move some toolbar item and Exit Customize mode
4. Click Chevron

Actual Results:
Chevron is broken.

Expected Results:
Chevron bookmark menu should pop up
Duplicate of this bug: 940027
Whiteboard: [Australis:P1]
It seems that exiting customization mode, the scrollbox for PlacesToolbarItems isn't firing/catching the overflow events, and as such you can see in the screenshot that the overflowed item is just being clipped.
(In reply to Jared Wein [:jaws] from comment #2)
> It seems that exiting customization mode, the scrollbox for
> PlacesToolbarItems isn't firing/catching the overflow events, and as such
> you can see in the screenshot that the overflowed item is just being clipped.

This is on the money. We destroy the places view when entering customize mode, and then create a new one. But the new one doesn't seem to get an overflow/underflow event at that point, probably because it's created too late. It should check for that state in the places toolbar helper's customizeDone function. I'll try and come up with a patch.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Reworked the code a bit so it was more reusable, and this works like a charm, as far as I can tell. Might fix some of our other issues, too...
Attachment #8343299 - Flags: review?(jaws)
remote:   https://hg.mozilla.org/integration/fx-team/rev/09714c24277b
Whiteboard: [Australis:P1] → [Australis:P1][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/09714c24277b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P1][fixed-in-fx-team] → [Australis:P1]
Target Milestone: --- → Firefox 28
Depends on: 1358724
You need to log in before you can comment on or make changes to this bug.