Win64 compiler warning in jsapi.h(2300) : warning C4267: 'argument' : conversion from 'size_t' to 'int', possible loss of data

RESOLVED DUPLICATE of bug 722215

Status

()

defect
RESOLVED DUPLICATE of bug 722215
6 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Frequently spammed during Win64 builds.

jsapi.h(2300) : warning C4267: 'argument' : conversion from 'size_t' to 'int', possible loss of data

    jsid operator[](size_t i) const {
        JS_ASSERT(idArray);
        JS_ASSERT(i < length());
        return JS_IdArrayGet(context, idArray, i);
    }

Line 2300 is the return.
Blocks: 1072071
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 722215
You need to log in before you can comment on or make changes to this bug.