Sanctuary-20131107-with-idbfs - black screen after reaching the kill limit

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: pauly, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
STR:
1. play Sanctuary-20131107-with-idbfs until you reach the kill limit (25 kills)
2. when the camera moves above the character, just click on the screen couple of times

AR:
Unresponsive script error appeared.
Black screen over the game area.
In browser console: "Error: WebGL: A texture is going to be rendered as if it were black, as per the OpenGL ES 2.0.24 spec section 3.8.2, because it is a 2D texture, with a minification filter requiring a mipmap, and is not mipmap complete (as defined in section 3.7.10)."

Reproducible on FF 25-28
Reporter

Updated

6 years ago
Blocks: gecko-games
Again, doesn't sound like a JS bug (JS probably shouldn't be the default component when filing these unless there is a crash in what looks like jit code or the JS engine or there is some aberrant behavior that is fixed by toggling javascript.options.asmjs or javascript.options.ion.content).

Based on the warning, this might be WebGL or it might just be in the the app itself.  Tentatively moving to graphics, where people would understand this error.
Component: JavaScript Engine → Graphics
Sanctuary at that point tries to switch levels, which aren't in the emscripten package.  It then just dies and infinite-loops.  This isn't a bug on our end, it's a bug/issue in the actual C++ code.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.