If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsRegion.h:22: fatal error: 'pixman.h' file not found (--enable-system-pixman|enable-system-cairo)

RESOLVED DUPLICATE of bug 941595

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 941595
4 years ago
4 years ago

People

(Reporter: Jaroslav Kopecký, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
In file included from media/webrtc/signaling/src/media/VcmSIPCCBinding.cpp:18:
In file included from media/webrtc/signaling/./src/peerconnection/PeerConnectionMedia.h:28:
In file included from dist/include/Layers.h:40:
In file included from dist/include/nsRegion.h:22:
dist/system_wrappers/pixman.h:3:15: fatal error: 'pixman.h' file not
      found
#include_next <pixman.h>
              ^
1 error generated.
gmake[3]: *** [VcmSIPCCBinding.o] Error 1
(Reporter)

Updated

4 years ago
Blocks: 845874
(Reporter)

Updated

4 years ago
Summary: nsRegion.h:22: fatal error: 'pixman.h' file not found (--with-system-cairo) → nsRegion.h:22: fatal error: 'pixman.h' file not found (--enable-system-cairo)
(Reporter)

Comment 1

4 years ago
In file included from gfx/tests/gtest/TestAsyncPanZoomController.cpp:11:
In file included from dist/include/mozilla/layers/AsyncCompositionManager.h:10:
In file included from dist/include/mozilla/layers/LayerManagerComposite.h:11:
In file included from gfx/layers/Layers.h:40:
In file included from dist/include/nsRegion.h:22:
dist/system_wrappers/pixman.h:3:15: fatal error: 'pixman.h' file not found
#include_next <pixman.h>
              ^
1 error generated.
gmake[1]: *** [TestAsyncPanZoomController.o] Error 1
(Reporter)

Comment 2

4 years ago
In file included from dom/camera/DOMCameraPreview.cpp:6:
In file included from dist/include/Layers.h:40:
In file included from dist/include/nsRegion.h:22:
dist/system_wrappers/pixman.h:3:15: fatal error: 'pixman.h' file not found
#include_next <pixman.h>
              ^
1 error generated.
gmake[1]: *** [DOMCameraPreview.o] Error 1
(Reporter)

Comment 3

4 years ago
In file included from content/base/src/Element.cpp:97:
In file included from dist/include/nsView.h:12:
In file included from dist/include/nsRegion.h:22:
dist/system_wrappers/pixman.h:3:15: fatal error: 'pixman.h' file not found
#include_next <pixman.h>
              ^
1 error generated.
gmake[1]: *** [Element.o] Error 1
(Reporter)

Comment 4

4 years ago
In file included from content/events/src/nsEventStateManager.cpp:55:
In file included from layout/generic/nsSubDocumentFrame.h:10:
In file included from layout/generic/nsLeafFrame.h:13:
In file included from dist/include/nsDisplayList.h:23:
In file included from dist/include/nsRegion.h:22:
dist/system_wrappers/pixman.h:3:15: fatal error: 'pixman.h' file not found
#include_next <pixman.h>
              ^
1 error generated.
gmake[1]: *** [nsEventStateManager.o] Error 1
(Reporter)

Comment 5

4 years ago
In file included from content/html/content/src/HTMLCanvasElement.cpp:12:
In file included from dist/include/Layers.h:40:
In file included from dist/include/nsRegion.h:22:
dist/system_wrappers/pixman.h:3:15: fatal error: 'pixman.h' file not
      found
#include_next <pixman.h>
              ^
1 error generated.
gmake[1]: *** [HTMLCanvasElement.o] Error 1

Comment 6

4 years ago
Yes, I'm working on a patch for it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Summary: nsRegion.h:22: fatal error: 'pixman.h' file not found (--enable-system-cairo) → nsRegion.h:22: fatal error: 'pixman.h' file not found (--enable-system-pixman|enable-system-cairo)
Component: Graphics → Build Config
Created attachment 8341539 [details] [diff] [review]
first attempt: add MOZ_PIXMAN_CFLAGS in Makefile.in for some of the directories that need it

This approach seems to be getting out of control.  I don't know how many more directories would need this.
Attachment #8341539 - Attachment is patch: true
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 941595
You need to log in before you can comment on or make changes to this bug.