Closed Bug 940437 Opened 8 years ago Closed 7 years ago

TB 24.0.1 unable to change text color

Categories

(Thunderbird :: Message Compose Window, defect)

24 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 883540

People

(Reporter: wayne, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.57 Safari/537.36

Steps to reproduce:

Reply to an email. Select text and then click the color icon in the toolbar to change color. (Note: ONLY happens when Replying. Composing new email works just fine).

More details at this thread here:
http://forums.mozillazine.org/viewtopic.php?f=39&t=2757851


Actual results:

Nothing happens when you click the color box.


Expected results:

the colors box should open to select a color for the highlighted text.
howdy y'all,

my setup ...
os = win7x32, sp1
tb = 24.1.1
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Thunderbird/24.1.1

FYI, this is the mozillazine thread where i ran across this situation. i _cannot_ reproduce it, tho.
TB 24.0.1 unable to change text color • mozillaZine Forums - http://forums.mozillazine.org/viewtopic.php?f=39&t=2757851

i tried it in tb 24.1.0 and 24.1.1 without this bug showing up for me. here are the steps i used ...
- select a msg
- reply to that msg in HTML [my default is plaintext]
- select some text
- hit the "choose color for text" button on the formatting toolbar
- the "text color" dialog opens 
for me, it opens half on each of my dual monitor setup, so i need to move it to one monitor to be able to read it clearly. it still displays, tho.
- select a color [i used red] & hit OK
- click somewhere in the reply to remove the selection hilite and clearly display the text

at that point the formerly selected text will display in red.
*****

so it seems there is some currently unknown difference between my setup and the reporters setup.

take care,
lee
Hello,

One of my bosses is experiencing the same intermittent problem at his computer.  Our office has 5 work stations with the same version of Thunderbird, but his seems to be the only one with this problem so far.  I'll be watching to see if a fix shows up here.  As a work around for now, I've advised him to write his text in a new message, color it, and copy/paste it into replies where changing text color doesn't normally work.

Hope someone comes up with a more permanent solution.
Thanks
Hi Ray,
Yes it is an intermittent problem and seems to come ago, but I saw your comment and thought I would offer a somewhat easier solution in the meantime. 

If the color box pop up isn't working, it can still be accessed by going to Format > Text Color from the main menu. In my experience this brings up the color palette box even when clicking the color icon in the compose window does not. This way you can still change text colors in replies.

(In reply to Ray Boltz from comment #2)
> Hello,
> 
> One of my bosses is experiencing the same intermittent problem at his
> computer.  Our office has 5 work stations with the same version of
> Thunderbird, but his seems to be the only one with this problem so far. 
> I'll be watching to see if a fix shows up here.  As a work around for now,
> I've advised him to write his text in a new message, color it, and
> copy/paste it into replies where changing text color doesn't normally work.
> 
> Hope someone comes up with a more permanent solution.
> Thanks
Thank you Wayne,
This works well and my boss appreciates the easier work around you suggested.  Now I'm beginning to wonder how much of this problem is related to popup blocking.  I don't know of any settings in Thunderbird that control this, but there are in Firefox and perhaps the two are related somehow...
(In reply to wayne from comment #3)
> Hi Ray,
> Yes it is an intermittent problem and seems to come ago, but I saw your
> comment and thought I would offer a somewhat easier solution in the
> meantime. 
> 
> If the color box pop up isn't working, it can still be accessed by going to
> Format > Text Color from the main menu. In my experience this brings up the
> color palette box even when clicking the color icon in the compose window
> does not. This way you can still change text colors in replies.
> 
> (In reply to Ray Boltz from comment #2)
> > Hello,
> > 
> > One of my bosses is experiencing the same intermittent problem at his
> > computer.  Our office has 5 work stations with the same version of
> > Thunderbird, but his seems to be the only one with this problem so far. 
> > I'll be watching to see if a fix shows up here.  As a work around for now,
> > I've advised him to write his text in a new message, color it, and
> > copy/paste it into replies where changing text color doesn't normally work.
> > 
> > Hope someone comes up with a more permanent solution.
> > Thanks
howdy y'all,

this may be related ...
933782 – Font colour not working in formatting Bar 
- https://bugzilla.mozilla.org/show_bug.cgi?id=933782

take care,
lee
Have updated to TB 24.2.0 and so far issue has not reappeared. Quite possibly resolved in latest release.
I'm running TB 24.2.0 and the problem is definitely still there.  I've seen this problems in earlier versions of TB (last six months) and the problem continues to exist in the latest release.  As the OP noted the problem is seen my most, if not all, when replying to an email.  As many folks, when replying to an email, like to change the text color to identify their email response more easily in contrast to the original context of the received email they try to change the color of their text.  This problem is apparent when one attempts to click on the "choose color for text" icon.  A text color selection window "SHOULD" pop up but alas it does not.  Also, TB developers should note the problem does NOT always reveal itself.  For example, simply closing the TB app then restarting it SOMETIMES temporarily resolves the problem.  The problem may quickly reappear after performing one reply email, sending it, then trying to reply to another email where you attempt to change text colors.
FYI, I'm running Windows 7 - 64-bit and have the latest updates from MS.  Again, I'm running TB 24.2 but this problem existed in the last two versions of TB I was using.  It is apparently intermittent.  Sometimes the problem is there while at other times TB behaves properly.  You can see the long list of others having this problem here: http://forums.mozillazine.org/viewtopic.php?f=39&t=2757851&p=13317479#p13317479
This isn't just a problem with replies.  I consistently have a problem with the color picker not being available when, as I often do because I post a daily newsletter, I save an e-mail to the drafts folder then go back to add more text in a different color.  The work around is to exit the draft, go to the drafts folder, select the message and click on "edit", but it is annoying to have to do this all of the time.
Can you guys observe whether the problem appears after you save the message as draft? Or compose the message for long enough so that the message is automatically saved as draft (after the timeout set in TB options).
(In reply to :aceman from comment #10)
> Can you guys observe whether the problem appears after you save the message
> as draft? Or compose the message for long enough so that the message is
> automatically saved as draft (after the timeout set in TB options).

It seems to be very random.  I'm sure it's really not but no one has figured out the secret combination of events that causes the problem.  Per your request I did a couple of tests.  First I changed the auto save draft setting to 1 minute.  Then I started a reply to an email (which is usually when I observe the problem).  I'd try to highlight some of the text but observed the color selector was working correctly.  Next, I waited a few minutes and tried to highlight my reply text again but the color selector continued to work.  Next, I left the window up and came back an hour later and tried again but the color selector still worked.  The color selector seems to break only when I need to use it.  I also saved the reply as a draft then brought it back to edit mode and tried the color selector.  It worked again.  I just could not get this problem to occur in the test I performed although I can say that the problem showed up half a dozen times earlier in the day when I was trying to reply to emails.  When the color selector doesn't work I usually just highlight my reply text by making it appear in bold text so it stands out from the original email message.
Right, I have now tried it and the Automatic save does not cause the bug. Only the manual does.
But what you describe in comment 7 (compose, send, compose another -> color does not work) is also a way to reproduce it.

I'm just trying out if your problems get fixed by bug 883540. We will probably see at TB 24.4.
I can consistently reproduce this problem by doing the following in TB 24.2.0.

a) With TB closed I open up a new session of the TB application.

b) I compose a new email to myself with the word "test" in the body of the message.  I successfully use the color picker to change the color of the word "test" from black to red.  The email is sent.

c) When the email from the previous step is received I do a reply to it.  In that reply message I attempt to use the color picker to change the color of the word "test" to another color but the color picker pop-up doesn't appear.

3 out of 3 times I did steps a, b, and c above I consistently reproduced the problem.
Great. But in step c) what happens if you just compose a new message instead of replying to one?
(In reply to :aceman from comment #14)
> Great. But in step c) what happens if you just compose a new message instead
> of replying to one?

The color picker works if I don't attempt to reply to the email I sent myself and only compose a new email to myself.
The consistent "fix" to the color picker not working when attempting to compose a reply email is to do the following:

Before hitting the "Replay" button, first hit the "Write" button like you want to compose a new email.  Doing that first somehow resets the color picker.  However, keep the window that popped for the new email and leave it alone in the background.  With that popup window still active hit the "Reply" button for the email you want to reply to and note the color picker now works all the time when trying to do a reply using this process.  This seems like the easiest workaround but should also be a clue to developers when attempting to fix the bug.
Can you guys test it now in TB 24.4.0 ?
I updated to TB 24.4.0 and tried the same test I identified in "Comment 13" above.  So far, so good.  The color picker now is working correctly as expected when doing reply emails.  Of course my test isn't extensive so only time will tell but for now the fix look promising.
TB 24.4.0 has solved the problem I was experiencing.
Thanks for fixing this!
I have been testing this since yesterday. Leaving the Reply box open for awhile, trying it when first opening the reply, trying it on multiple emails, testing in the compose email, etc. and yes....so far the issue appears to be resolved in TB 24.4.0 :) I will report back if anything changes but so far so good!

I really appreciate the hard work you guys put in to fixing this very minor flaw.
OK, I dupe this to the bug where a fix was merged into TB24. Please comment if any of you can still reproduce the problem with TB24.4.0
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 883540
Problem solved by changing one setting! Confirmed fixed for us using version 31.6.0. Tools --> Options --> Click the colors button --> Check the box that says "Allow content to choose its own colors, instead of my selections above. Whallah, fixed.
You need to log in before you can comment on or make changes to this bug.