offline: Mac : download a message approx 1mb in size causes crash?

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Backend
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: grylchan, Assigned: Bienvenu)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
2001-08-06-08-trunk/ on MAC os 9.0.4

Trying to download message (was trying test bug 91679) and I
get this strange crash when trying to download a message.
So far this only happens on MAC. I don't think its related
to bug 91679.

I get the mac error: "Netscape 6 has unexpectedly quit, because
of an error of type 2 occurred". OR "Netscape 6 has unexpectedly quit, because
of an error of type 10 occurred"

Reproducibility: sometimes

Steps to reproduce:
1.Login to your imap mail account (i had deletion model set to mark
  as deleted, this shouldn't make a difference)
2.Send yourself some different sized mail messages with attachments
  so the size of the message varies form say 600kb to approx 1 or 2mb
  in size.
  -my attachments included ultra edit exe,ws_Ftp exe, some windows dll
   files, a mpeg file
3.Select a message
4.File|offline|Get Selected Message
5.Repeat steps 3 & 4 until crash happens. (I may have gone offline,
  clicked on one of the downloaded messages, then gone back online to
  repeat steps 3 and 4.)


Result: crash may occur. Doesn't always crash, nor does it crash on the
        same message. Kind of random.

I wish I could give exact steps to reproduce. I have yet to
see it happen on Windows/Linux. Not sure it's size of the message,
or just downloading a message that is causing the crash.

talkback ids:
http://climate.mcom.com/reports/incidenttemplate.cfm?bbid=33814666
http://climate.mcom.com/reports/incidenttemplate.cfm?bbid=33814038
http://climate.mcom.com/reports/incidenttemplate.cfm?bbid=33815607

Notice 2 of talkback id trigger reasons are 'PowerPC unmapped memory exception '
and the other one is 'Illegal PowerPC instruction' but in stack
trace they crash at exact same spot.

Updated

17 years ago
Keywords: nsenterprise

Updated

17 years ago
Keywords: nsenterprise → nsenterprise+
(Assignee)

Comment 1

17 years ago
I don't have a mac, so I can't debug this. Is it possible that it has nothing to
do with the size of the messages downloaded? Can you recreate it by downloading
small messages , e.g., in a bugsplat folder, select a message, do a file |
offline |get selected messages, select another message, repeat until it crashes?
I'm wondering if perhaps we're having trouble opening the offline store because
it's still open? Is it possible that  in the case where you're downloading a
large message for offline use, that you've  started downloading the second
message for offline use before the first message has finished downloading? (in
which case it would have to do with downloading large messages).
Or here's another test you could do:

1. Select a bunch of large messages and do a "download selected for offline".
Then, while that's going on, select another bunch of large messages, and do a
"download selected for offline" on that second selection. If the problem is
opening the offline store, that would crash as well.
(Assignee)

Comment 2

17 years ago
I tried this for a while and could not reproduce the problem. I'd recommend we
triage this out.
Status: NEW → ASSIGNED
(Reporter)

Comment 3

17 years ago
hey David. i'll give it a whack first thing tommorrow. But
will go with your recommendation..
(Assignee)

Comment 4

17 years ago
OK, thanks, Gary. I tried a bunch of things and was unable to get it to crash,
so I'm curious what you find.
(Reporter)

Comment 5

17 years ago
David.

I can't reproduce this bug with 2001082408 commercial trunk build
on mac 9.0.4.

I tried doing my steps. No luck. Tried your test of downloading
big messages almost simultaneously (do get mesg on big file, then
while it's downloading, do another get mesg on another big file)
and they work as expected no crash. I even was using same
mail account/mail messages that I tested earlier with and nothing..

I'm at a lost. I'm going to resolve this as works for me and
if I run into this prob again, i'll reopen. Thanks!

Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.