If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

devicemanagerSUT.pullFile fails when filename contains certain unicode characters

RESOLVED WONTFIX

Status

Testing
SUTAgent
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: gbrown, Assigned: gbrown)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
As described at https://bugzilla.mozilla.org/show_bug.cgi?id=938706#c7:

18:14:03     INFO -  TEST-INFO | /builds/panda-0526/test/build/tests/xpcshell/tests/netwerk/test/unit/test_safeoutputstream.js | running test ...
18:14:03     INFO -  TEST-PASS | /builds/panda-0526/test/build/tests/xpcshell/tests/netwerk/test/unit/test_safeoutputstream.js | test passed (time: 635.871ms)
18:14:03     INFO -  INFO | Following exceptions were raised:
18:14:03     INFO -  Traceback (most recent call last):
18:14:03     INFO -    File "/builds/panda-0526/test/build/tests/xpcshell/runxpcshelltests.py", line 145, in run
18:14:03     INFO -      self.run_test()
18:14:03     INFO -    File "/builds/panda-0526/test/build/tests/xpcshell/runxpcshelltests.py", line 671, in run_test
18:14:03     INFO -      if self.checkForCrashes(self.tempDir, self.symbolsPath, test_name=name):
18:14:03     INFO -    File "/builds/panda-0526/test/build/tests/xpcshell/remotexpcshelltests.py", line 142, in checkForCrashes
18:14:03     INFO -      self.device.getDirectory(self.remoteTmpDir, dumpDir)
18:14:03     INFO -    File "/builds/panda-0526/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 673, in getDirectory
18:14:03     INFO -      self.getFile(remotePath, localPath)
18:14:03     INFO -    File "/builds/panda-0526/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 645, in getFile
18:14:03     INFO -      data = self.pullFile(remoteFile)
18:14:03     INFO -    File "/builds/panda-0526/test/build/venv/lib/python2.7/site-packages/mozdevice/devicemanagerSUT.py", line 634, in pullFile
18:14:03     INFO -      raise DMError("DeviceManager: pulling file '%s' unsuccessful: %s" % (remoteFile, error_str))
18:14:03     INFO -  DMError: DeviceManager: pulling file '/mnt/sdcard/tests/xpcshell/tmp/ओ' unsuccessful: No such file or directory
18:14:03     INFO -  Traceback (most recent call last):
18:14:03     INFO -    File "/builds/panda-0526/test/build/tests/xpcshell/remotexpcshelltests.py", line 577, in <module>
18:14:03     INFO -      main()
18:14:03     INFO -    File "/builds/panda-0526/test/build/tests/xpcshell/remotexpcshelltests.py", line 572, in main
18:14:03     INFO -      **options.__dict__):
18:14:03     INFO -    File "/builds/panda-0526/test/build/tests/xpcshell/runxpcshelltests.py", line 1462, in runTests
18:14:03     INFO -      raise exceptions[0]
18:14:03     INFO -  mozdevice.devicemanager.DMError: DeviceManager: pulling file '/mnt/sdcard/tests/xpcshell/tmp/ओ' unsuccessful: No such file or directory
18:14:03    ERROR - Return code: 1
(Assignee)

Updated

4 years ago
See Also: → bug 938706
(Assignee)

Comment 1

4 years ago
It looks like the problem is in sutagent. pullFile sends "pull /mnt/sdcard/tests/xpcshell/tmp/ओ" and receives metadata response "##AGENT-WARNING## /mnt/sdcard/tests/xpcshell/tmp/ओ,-1"
(Assignee)

Comment 2

2 years ago
We worked around this in bug 938706 and it hasn't caused further trouble.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Component: Mozbase → SUTAgent
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.