Closed Bug 940623 Opened 7 years ago Closed 7 years ago

Check in the slave (builder) scripts that are used to drive NSS buildbot automation

Categories

(NSS :: Build, defect)

3.15.4
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
3.15.4

People

(Reporter: KaiE, Assigned: KaiE)

Details

Attachments

(1 file)

We have been using scripts to drive the buildbot/buildmaster build and testing automation. They have been stable (no changes) since March 2013.

The scripts aren't yet checked in to NSS (they are currently hosted in a private repository).

I propose to check them in at
  nss/automation/buildbot-slave

(at a laster time we might check in buildbot master configuration at
  nss/automation/buildbot-master )
Attached patch patchSplinter Review
I'm asking for approval to checkin.

Please review if you are OK with the place I'm adding the scripts.

I'm not asking for a review. It required some trial and error to get them working.

This is what we are already using in production. At this time I don't want to work on optimizing the scripts. Please allow me to check them in.

(If you want to review the scripts and request change, please let's do that in a follow-up.)
Assignee: nobody → kaie
Attachment #8334769 - Flags: review?(rrelyea)
Summary: Check in the scripts that are used to drive NSS buildbot automation → Check in the slave (builder) scripts that are used to drive NSS buildbot automation
Comment on attachment 8334769 [details] [diff] [review]
patch

r+ yes please check them in.

bob
Attachment #8334769 - Flags: review?(rrelyea) → review+
https://hg.mozilla.org/projects/nss/rev/216cbcfe2705
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.15.4
You need to log in before you can comment on or make changes to this bug.