When launching FF fresh with a URL, URL doesn't display in address bar.

NEW
Unassigned

Status

()

Firefox
Address Bar
4 years ago
2 years ago

People

(Reporter: abcdzywx, Unassigned)

Tracking

25 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

(This was done on Windows 8.  May affect other platforms too.)

Without a Firefox process already running, launch firefox.exe with a URL argument -- or, if Firefox is the default HTTP protocol scheme handler, launch a URL from the system.  Observe the address bar while the page is loading.

Note: This works better if you use a non-existent URL, such as "http://a", and if you have "keyword:enabled" and ""browser.fixup.alternate.enabled" both disabled.  This takes a long time to fail, during which this issue can be clearly observed.


(Control experiment: Do the same as above, except with a Firefox window already running at time 0.)


Actual results:

When the Firefox process was not running at time 0, and Firefox was launched with a URL, the URL does not display in the address bar while the page is loading or attempting to load.  The address bar remains blank, with the background text "Search or enter address".  Once the page either loads successfully or fails to load, the URL is then displayed in the address bar.


(On the contrary, in the control experiment, when Firefox was running at time 0 and a URL is loaded into Firefox from the system, then a new tab is opened with the URL displaying even while the page is loading.)


Expected results:

The URL should display in the address bar while the page is loading even when Firefox is being launched anew.  There should not be non-uniform behavior when calling a URL with a Firefox process already running at time 0 versus not already running at time 0.


Note: Bug 900772 seems to be a similar sighting, except in that case, with an older Firefox version, an add-on was found the be causing the issue.  In this case, however, I am able to reproduce this even in Safe Mode (with the "-safe-mode" argument in addition to the URL argument and saying "yes" to the prompt), which disables add-ons.

Comment 1

2 years ago
Hello Reporter, Thanks for reporting this issue and sorry for getting back to you so late. I tried duplicating this behavior with all different scenario and steps you mentioned on following versions and was able to reproduce this. 

Name 	Firefox
Version 	46.0a1
Build ID 	20160112030227
Update History 	
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0

Name 	Firefox
Version 	43.0.4
Build ID 	20160105164030
Update History 	
Update Channel 	release
User Agent 	Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0

I also tested on IE and I could see the difference, URL is displayed in IE at time 0.
Status: UNCONFIRMED → NEW
Component: Untriaged → Networking
Ever confirmed: true
Product: Firefox → Core

Updated

2 years ago
Component: Networking → Location Bar
Product: Core → Firefox
You need to log in before you can comment on or make changes to this bug.